tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bill <bhal...@collaborativefusion.com>
Subject mod_jk apache2 tomcat4.1.8
Date Wed, 15 Jan 2003 16:16:51 GMT
I'm still having problems using mod_jk with Apache2.  The "unable to
open config" error seems to have gone away, the incomplete read errors
are still there.  I started fresh on a new box so I'll re-submit the
relevant info:

##http.conf##
 
LoadModule              jk_module       modules/mod_jk.so
JkWorkersFile           /usr/local/tomcat/conf/jk/workers.properties
JkLogFile               /usr/local/apache2/logs/mod_jk.log
JkLogLevel              error
JkLogStampFormat        "[%a %b %d %H: %M: %S: %Y] "


Include /usr/local/tomcat/conf/auto/mod_jk.conf

##mod_jk.conf

<VirtualHost 192.168.1.13>
    ServerName 192.168.1.13

    JkMount /examples ajp13
    JkMount /examples/* ajp13

    JkMount /webdav ajp13
    JkMount /webdav/* ajp13

    JkMount /tomcat-docs ajp13
    JkMount /tomcat-docs/* ajp13

    JkMount /manager ajp13
    JkMount /manager/* ajp13

    JkMount /admin ajp13
    JkMount /admin/* ajp13
    
    JkMount /cores ajp13
    JkMount /cores/* ajp13

    JkMount /mrccores ajp13
    JkMount /mrccores/* ajp13
</VirtualHost>

##workers.properties##

worker.list=ajp13
worker.ajp13.type=ajp13
worker.ajp13.host=192.168.1.13
worker.ajp13.port=8009

worker.ajp13.cachesize=10
worker.ajp13.cache_timeout=600
worker.ajp13.socket_keepalive=1
worker.ajp13.socket_timeout=300

##server.xml##
<Server port="8005" shutdown="SHUTDOWN" debug="0">

  <Listener
className="org.apache.catalina.mbeans.ServerLifecycleListener"
            debug="0"/>
  <Listener
className="org.apache.catalina.mbeans.GlobalResourcesLifecycleListener"
            debug="0"/>

  <!-- Global JNDI resources -->
  <GlobalNamingResources>

    <!-- Test entry for demonstration purposes -->
    <Environment name="simpleValue" type="java.lang.Integer"
value="30"/>

    <!-- Editable user database that can also be used by
         UserDatabaseRealm to authenticate users -->
    <Resource name="UserDatabase" auth="Container"
              type="org.apache.catalina.UserDatabase"
       description="User database that can be updated and saved">
    </Resource>
     <ResourceParams name="UserDatabase">
      <parameter>
        <name>factory</name>
       
<value>org.apache.catalina.users.MemoryUserDatabaseFactory</value>
      </parameter>
      <parameter>
        <name>pathname</name>
        <value>conf/tomcat-users.xml</value>
      </parameter>
    </ResourceParams>

  </GlobalNamingResources>

<Service name="Tomcat-Apache">

    <Connector className="org.apache.ajp.tomcat4.Ajp13Connector"
acceptCount="10" debug="0"/>
    <Engine name="Apache" defaultHost="192.168.1.13" appBase="webapps"
               debug="0">

      <Logger className="org.apache.catalina.logger.FileLogger"
              prefix="apache_log." suffix=".txt"
              timestamp="true"/>

      <Realm className="org.apache.catalina.realm.MemoryRealm" />
      <Host name="192.168.1.13" debug="0" appBase="webapps"
unpackWARs="true">
        <Listener className="org.apache.ajp.tomcat4.config.ApacheConfig"
                append="true" />
        <Valve className="org.apache.catalina.valves.AccessLogValve"
                directory="logs" prefix="host_access_log." suffix=".txt"
                pattern="common" />
        <Context path="" docBase="ROOT" reloadable="true" debug="0"/>

        <Context path="/cores" docBase="mrccores" reloadable="true"
debug="0"/>
    </Host>
    </Engine>

  </Service>

</Server>

The only error I'm getting is this in apache_log.txt:

Ajp13Processor[8009][4] [Ajp13] incomplete read, waited #-1 got only 0

I havent found any other problems...

-b




--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message