tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Yakov Belov" <ybe...@brainresource.com>
Subject PJA libraries
Date Thu, 23 Jan 2003 00:00:58 GMT
Dear All,

I tried to use PJA libraries (pure java implementation of java.awt library) to draw charts
from my servlet.

The essential code changes are:

System.setProperty ("awt.toolkit", "com.eteks.awt.PJAToolkit");
System.setProperty ("java.awt.graphicsenv","com.eteks.java2d.PJAGraphicsEnvironment");
System.setProperty ("java.awt.fonts", "/usr/share/fonts/default/TrueType");

These changes are specified by the creators of PJA.

I placed pja.jar and pjatools.jar and servlet.jar (required files) under the WEB-INF/lib directory
of my application.

When I run the app I receive the following:

java.lang.Error: Could not find class: com.eteks.java2d.PJAGraphicsEnvironment

This is strange as pja.jar contains this class, which isn't found acording to the message,
and pja.jar is, as I said earlier, under WEB-INF/lib.

I think the problem is that com.eteks.java2d.PJAGraphicsEnvironement class never is linked
when compilation occures, as it is never referenced in the code, only as a text reference,
or something along those lines.

Can anyone see a problem here or can suggest trying something?

Best Regards,
Yakov





Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message