tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Balaji Venkatachari" <bal...@hometracker.com>
Subject Tomcat 4.0.1 stops responding
Date Fri, 10 Jan 2003 22:19:49 GMT
We have been using Tomcat 4.0.1 for our production server for last 1 yr.
We have a web based JSP/Servlet application using JDBC to connect to SQL
server 2000 database.
 
For the past 2 weeks, the Tomcat has periodically stopped responding,
gradually decreasing in performance, until it comes to a halt. I have to
bounce the server and it stays OK for a couple of hours and the same
problem re-appears.
 
During the time when performance starts degrading, a lot of
threads(sometimes>300) are created. Our max thread count is set to 600.
But during the past 1 yr(when performance was superb), I've never seen
thread count go past 150 or so.
 
The application log indicates that all of a sudden, the session objects
are lost and lots of new threads are
created within a short burst of time.
 
I tried finding co-releation with any user activity(like running
reports, more users etc.) when this problem occurs.
But I couldn't find a pattern.
 
All the log information appear to tell me the results of the problem.
but I can't seem to go beyond that.
Has anyone seen such behavior? How should I go about debugging this?
 
Any help would be vastly appreciated since it's an ongoing production
issue.
 
 
Balaji Venkatachari
 

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message