tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Christophe Sebille" <>
Subject Not retrieving home made trusted certificates
Date Thu, 09 Jan 2003 10:09:28 GMT

  The aim is to use a server ( Tomcat ) to authenticate web users thanks to
their certificate.

  I've imported with keytool trusted certificates made by OpenSsl when
Iuse -list option I have for each certificate a 'trustedCertEntry'
indication ( the CA certificate have been imported with -trustcacerts
option ). It seems Ok.

  So I run Tomcat with option. No certificate is
prompted. I tried the -genkey method, the key is seen at jvm starting but at
handshake with the client I have a 'Could not find trusted certificate'
fatal, description = certificate_unknown ( I understand that because client
certificate and generated key don't match ).

  I don't know where I'm wrong, maybe it's in Tomcat's configuration. I'd
like to know what's prompted where everythiing runs well.

Thanks in advance,


To unsubscribe, e-mail:   <>
For additional commands, e-mail: <>

View raw message