tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vivek Singh" <vivek.si...@wipro.com>
Subject TOMCAT listening on 80 Thanks John-Turner/Jan-Michael/seemanto/Donie/Anyone....
Date Tue, 07 Jan 2003 11:52:13 GMT
BINGO!!!!!!!!!!!!!!!!!!!!!!!!!!!

   IT is working at last at port 80. All services still running.
 Reason; screwed up server.xml.
 Gotta watch those tags next time. 

     But I still have tomcat running at 8080. How do I stop it at 8080?



-----Original Message-----
From: Turner, John [mailto:JTurner@AAS.com] 
Sent: Tuesday, January 07, 2003 4:49 PM
To: ''Tomcat Users List' '
Subject: RE: RE: TOMCAT Not listening on 80
John-Turner/Jan-Michael/seemanto/Donie/Anyone....

 
Yeah, your server.xml file is screwed up, which is why you aren't
getting
anything in mod_jk.conf, which is why Apache doesn't have any JK
directives,
which is why Apache doesn't understand what to do with JSP and servlet
URLs.

Fix your server.xml, sounds like you have a tag out of place or you have
a
tag terminated incorrectly.  If everything is fixed, you WILL ALWAYS get
content in mod_jk.conf.  If you don't, if mod_jk.conf is empty, there is
something seriously wrong on the Tomcat side in server.xml.

You can always just add the JK directives to httpd.conf directly, there
is a
link to a mod_jk.conf file on my site that has what you need or will at
least provide a guideline.

John

-----Original Message-----
From: Vivek Singh
To: 'Tomcat Users List'; vivek.singh@wipro.com
Sent: 1/7/03 4:35 AM
Subject: RE: RE: TOMCAT Not listening on 80
John-Turner/Jan-Michael/seemanto/Donie/Anyone....

Hi ,
           I just noticed that when I try opening the server XML file I
get this error. 

End tag 'Host' does not match the start tag 'Engine'. Line 388, Position
9 
 

      </Host>
--------^

   Any feedback!!

 Regards
                ~Vivek

-----Original Message-----
From: Vivek Singh [mailto:vivek.singh@wipro.com] 
Sent: Tuesday, January 07, 2003 2:56 PM
To: 'Tomcat Users List'
Subject: RE: RE: TOMCAT Not listening on 80
John-Turner/Jan-Michael/seemanto/Donie/Anyone....


Hi Guys,

          Here is what is happening now with very precise info. I think
I was dealing at a very high level so far. . I am running apache 1.3.19
+ tomcat 4.1.18 and modjk 1.2.1 
I have given the URL down from where I got the entire .so module,no
building was done just a copy from Jakarta web site to the apache module
directory.

Now this is the picture on the linux server.

http://192.168.132.34 is a test page from apache. 
http://192.168.132.34/bugzilla is a perl-CGI application sitting on port
80. 
http://192.168.132.34:8080 tomcat's page
http://192.168.132.34:8080/examples/jsp/index.html shows me JSP samples.

They execute very well

http://192.168.132.34:8080/examples/servlets/index.html shows me
servelets they execute very well.


PAGE NOT FOUND ERRORS for http://192.168.132.34/examples/jsp/index.html
http://192.168.132.34/examples/servlets/index.htm;


Pl. Look for----->
          <-------- comments.

  I am attaching all the configs file as mentioned by Jan/John. The
mod_jk.conf file is always empty after I deleted the contents,since I
assumed that it would be autogenrated. But it never did.

 I edited the contents of server.xml and insered workers.properties from
John's website, Just retyping the URL again..

http://www.johnturner.com/howto/apache2-tomcat4110-jk-howto.html

Thanks Again.....

  Hope to hear a LOT!!
   ~Vivek

-----Original Message-----
From: jmong@adobe.com [mailto:jmong@adobe.com] 
Sent: Monday, January 06, 2003 9:44 PM
To: Tomcat Users List
Subject: Re: RE: TOMCAT Not listening on 80

Hi there,
Hi vivek,

John Turner's suggestion is right on. Try setting it up on a 
development box first. This will save you and your colleagues a lot of 
headaches later on. Besides it is good practice. But here are some 
pointers.

-------->
 I have shifted the Bugzilla MySQL DB on a different box and 
 ghosted the server too
so I damn well have a contingency plan. Haven't I.
Let's not worry about it anymore.... If anything goes crazy I will ghost
it again. 
<----------

1. Log in as root or su to it
su - 

--------->
       one of the reasons why I write to user groups :-)
<----------

2. Search for perl
which perl or whereis perl
This should return /usr/bin/perl or /usr/local/bin/perl

------------------>
/usr/bin/perl
<------------------

3. Check the version
/path/to/perl -V
Note this version

---------->
  5.6.0
<----------

4. Search for apachectl
cd / ; find . -local -name 'apachectl' -print
This might take a while but should list where apachectl is located

----------------->
 I had apache 1.3.27 from redhat and unluckily rpm does not install bin
directory  anywhere. SO I use servie httpd restart,stop,start and etc to
reread httpd.conf. 

But wait I did find this file in one of the oracle 9i home
        ./home/oracle/product/9.0.1/Apache/Apache/bin/apachectl on the
same machine, yeah the big box runs almost everything.
   oracle 9i uses this for it's web applications on this server. So I
ran this file with configtest,it said Syntax OK. I did a more on it as
well and it uses 'bash' as the interpreter. (( I see where the perl
thing came from :-)
<--------------------

4a. Search for workers.properties
cd / ; find . -local -name 'workers.properties' -print
Note this location as this is what you'll put in JkWorkersFile later on

--------->
/usr/local/jakarta-tomcat-4.1.18/conf/jk/workers.properties
  I typed everything from John Turner's site accordingly, changed the
path of module as far as I know it well.
   I had to create this directory jk after after I learned I require it 
 BTW: -local gave invalid predicate on my linux RH 7.1 
<---------

5. Run apachectl configtest
/path/to/apachectl configtest
It should return 'Syntax OK' if everything is okay. If it returns 'not 
found' check to make sure that the first line of apachectl is your perl 
binary

-------->
         IT did OK
<-------

more apachectl
#!/path/to/perl  <-- should match step 2

---->
   no that's sh  in oracle's apache(not on the port 80)

<----

6. Check to make sure that you have the Tomcat connectors installed and 
search for mod_jk.so (JK1 I think) this should be in
$APACHE_HOME/libexec


--------------->
        I did not make this module but downloaded it from
Jakarta.apache.org. It was readymade as I did not find any src or binary
to build it. 
  Here is the link from which I got it. I simply copied it to the
/etc/httpd/modules where other apache modules are.
http://jakarta.apache.org/builds/jakarta-tomcat-connectors/jk/release/v1
.2.1/bin/linux/i386/ I downloaded mod_jk-1.3-eapi.so

as per the instruction on this page. 
<--------------------

7. There should be a couple of lines in your httpd conf along the 
following
LoadModule libexec/mod_jk.so
... [snip] ...
AddModule mod_jk.so

---->
         I also did add these line in httpd.conf, I added the Addmodule
line after reading point 7, but it was mod_jk.c not .so
<-------------

Read more on these directives on the apache website httpd.apache.org

8. Check apache's config and Restart apache
/path/to/apachectl configtest
/path/to/apachectl graceful

-------> 
I did this with service httpd restart not with this script.
<---------------

9. If this doesn't return an error, proceed with John's suggestions 
below.

As a side note, to configure tomcat to respond to 80 with apache you 
have to set up JKMount points and "redirect" jsp requests to tomcat 
(that's what the mod_jk.so is for)

Something like this in httpd.conf

--------------->
   Hooon!!!! So this is where the loopholes might be I did add these
line somewhere in httpd.conf with the exact path of workers.properties
without these '' ofcourse!! And I checked out the tomcat1 I think the
user is 'ajp13' there . I have the file attched  here for reference.
  Does it need to be a unix user or it is just a reference in context of
TOMCAT.?
<--------------------

JKWorkersFile '/path/to/workers.properties'
JKLogLevel debug

JKMount /examples/*.jsp tomcat1
JKMount /examples/servlet/*.jsp tomcat1 

Make sure that the "tomcat1" worker exists in workers.properties where 
you'll have to declare the worker and set some properties

I'm basing this off of tomcat 3.x it might have changed for 4.x

Try running a search off google also for "tomcat mod_jk tutorial" or 
just visit jakarta.apache.org
---------->
  I am planning it this weekend
<-----------------

Hope that helps.


GREAT!!!!!!!!!!!!!!!!!!

Jan-Michael




----- Original Message -----
From: "Turner, John" <JTurner@AAS.com>
Date: Monday, January 6, 2003 5:33 am
Subject: RE: TOMCAT Not listening on 80

> 
> Did you include a LoadModule line in Apache's config to load
> mod_jk?  You
> cannot use JK commands in httpd.conf unless you load a module that
> understands them.
> 
> Perhaps you might want to take a step back, tell us more
> specifically what
> you want to do, and perhaps consider setting up a test environment 
> that is
> not on a production server so that you can understand how to integrate
> Tomcat with Apache without interfering with your colleague's use 
> of your
> bugzilla installation.
> 
> John
> 
> > -----Original Message-----
> > From: Vivek Singh [mailto:vivek.singh@wipro.com]
> > Sent: Monday, January 06, 2003 6:43 AM
> > To: 'Tomcat Users List'
> > Subject: RE: TOMCAT Not listening on 80
> > 
> > 
> > John,
> >               I don't  remember doing any of these JkMount
> > directives, I
> > did not find any reference to this in your website, so there you go
> > :-)....
> > 
> >    And I had created a mod_jk.conf file in the path you had told and

> > included it at the end of httpd.conf, It had some autogenerated 
> > stuff in it put in my tomcat when I checked it later on..
> > 
> >     After that when I tried restarting apache it gave me this
> > error too
> > and did not come up.
> > 
> >  Invalid command 'JkWorkersFile', perhaps mis-spelled or defined
> by a
> > module not
> > included in the server configuration
> > 
> >  Then I echoed blanks in the file and Apache restared pretty
> well and
> > tomcat did not listen on 80.
> > 
> >  So let me give a try adding all this...
> > 
> > ~vivek
> > 
> > 
> > 
> > -----Original Message-----
> > From: Turner, John [mailto:JTurner@AAS.com]
> > Sent: Monday, January 06, 2003 4:48 PM
> > To: ''Tomcat Users List' '
> > Subject: RE: TOMCAT Not listening on 80
> > 
> >  
> > If you're saying that Apache's httpd.conf has no JkMount
> > directives for
> > JK,
> > then yes, your setup will never work.
> > 
> > If you've setup auto-generation according to my HOWTO, you can check

> > your Apache config prior to a restart as specified in my HOWTO, 
> > with:
> > 
> > /path/t>
> > provided you have an Include statement that includes 
> mod_jk.conf.
> > 
> > If you do have an Include statement, then you can simply
> > restart Apache
> > nicely with:
> > 
> > /path/t>
> > This will cause Apache to refuse new connection requests, 
> > wait until all
> > current connection requests are closed, and then reread 
> > httpd.conf.  It
> > all
> > happens in a second or two, it is highly doubtful that anyone 
> > would even
> > notice.
> > 
> > John
> > 
> > -----Original Message-----
> > From: Vivek Singh
> > To: 'Tomcat Users List'
> > Sent: 1/6/03 6:04 AM
> > Subject: RE: TOMCAT Not listening on 80
> > 
> > Won't stop it!!
> >  My team members will kill me if I stop it. I believe one of 
> > the reasons
> > why Tomcat cannot communicate with Apache is that I have no 
> > virtual host
> > thing going.  I might be wrong
> > 
> >   What do you think?
> > 
> >   ~Vivek
> > 
> > -----Original Message-----
> > From: Donie Kelly [mailto:donie.kelly@tecnomen.ie]
> > Sent: Monday, January 06, 2003 4:19 PM
> > To: 'Tomcat Users List'
> > Subject: RE: TOMCAT Not listening on 80
> > 
> > When you say you can't stop it do you mean "won't stop it?" or
> you are
> > unable to stop it?
> > 
> > Donie
> > 
> > 
> > -----Original Message-----
> > From: Vivek Singh [mailto:vivek.singh@wipro.com]
> > Sent: 06 January 2003 10:52
> > To: 'Tomcat Users List'
> > Subject: TOMCAT Not listening on 80
> > 
> > Hi,
> > 
> >              I did exactly as in the John Turner's website, Apache 
> > 1.3.27 with mod_jk and tomcat 4.1.18. To sum up here is what is 
> > happening
> > 
> >   1. I already have a Bugzilla running on my server at port80. Can't

> > stop it
> >   2. At port 8080 I can see Tomcat listening. I need it on 80 (
> Apache> is running here)
> > 
> > 
> > Can anyone help me?
> > 
> > 
> >   Thanks a lot in Advance and thanks John mail for Host Container 
> > clarifications
> > 
> > 
> > ~Vivek
> > 
> >   
> > 
> > 
> > 
> > --
> > To unsubscribe, e-mail: 
> > <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
> > For additional commands, e-mail: 
> > <mailto:tomcat-user-help@jakarta.apache.org>
> > 
> >  <<Wipro_Disclaimer.txt>>  <<ATT128036.txt>>
> > 
> > --
> > To unsubscribe, e-mail: 
> > <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
> > For additional commands, e-mail: 
> > <mailto:tomcat-user-help@jakarta.apache.org>
> > 
> > 
> 
> --
> To unsubscribe, e-mail:   <mailto:tomcat-user-
> unsubscribe@jakarta.apache.org>For additional commands, e-mail:
> <mailto:tomcat-user-help@jakarta.apache.org>
> 
> 

--
To unsubscribe, e-mail:
<mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail:
<mailto:tomcat-user-help@jakarta.apache.org>

 <<Wipro_Disclaimer.txt>>  <<ATT134050.txt>> 

--
To unsubscribe, e-mail:
<mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail:
<mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message