tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Antonio Vázquez <avazq...@winsoftsystems.com>
Subject Re: Apache 2.0 + Tomcat 4.1.12 + Realms + Java WebStart don't work
Date Wed, 15 Jan 2003 08:28:43 GMT
Holger,

I think that the problems was in the spanish and special characters "ñó()"
in the descriptions.

Thanks for your help

Antonio Vázquez
avazquez@winsoftsystems.com
www.winsoftsystems.com

----- Original Message -----
From: "Stratmann, Holger" <holger@cassiopeia.de>
To: "'Tomcat Users List'" <tomcat-user@jakarta.apache.org>
Sent: Tuesday, January 14, 2003 6:09 PM
Subject: AW: Apache 2.0 + Tomcat 4.1.12 + Realms + Java WebStart don't work


I was using Tomcat 4.1 with JavaWebStart (JWS) and it worked fine!

Does your realm work ok? IOW: Can you call html/jsp-pages which are access
protected?
Try calling a page that is in the same directory as the JNLP.

Also:
Which version of JavaWebStart are you using?
If you say: "the system" is unable to load the JNLP file, do you mean the
browser or do you mean JavaWebStart?
Do you use BASIC or form-based authentication? I use BASIC and I'm not sure
if (and how!) form-based could work...
(I was happy to see that JavaWebStart supported BASIC :-)

Let us know...
               Holger

Btw: As a hint for everybody who's using authentication w/ JavaWebStart:
I found it quite annoying to enter username/password every time I launch the
application (!!), just because JWS wants to check for updates. When you
press "Cancel" ("No, I don't want to check for updates..."), JWS does not
launch the application.
Then I found out that JWS uses the HEAD-method to check if files were
modified. GREAT!! You can use access-protection for everything but HEAD and
you're prompted for the password only if an update is available on the
server (which is usually a cool method...)

> -----Ursprüngliche Nachricht-----
> Von: Antonio Vázquez [mailto:avazquez@winsoftsystems.com]
> Gesendet: Dienstag, 14. Januar 2003 17:46
> An: Tomcat
> Betreff: Apache 2.0 + Tomcat 4.1.12 + Realms + Java WebStart
> don't work
>
>
> I have a little problem with Apache 2.0 + Tomcat 4.1.2 using
> JDBC Realms and
> Java WebStart.
>
> If i configure the web application a call the JNLP file, all
> works, but when
> I include  a REALM, the system is unable to load de JNLP file.
>
> I made several test and I am sure that the problem is when
> you use realm
> logins.
>
> Any idea?
>
> Thanks
> Antonio Vázquez
> avazquez@winsoftsystems.com
> www.winsoftsystems.com
>
>
> --
> To unsubscribe, e-mail:
> <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
> For additional commands, e-mail:
> <mailto:tomcat-user-help@jakarta.apache.org>
>

--
To unsubscribe, e-mail:
<mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail:
<mailto:tomcat-user-help@jakarta.apache.org>





--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message