tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joakim Ström <Joakim.St...@excosoft.se>
Subject Large files corrupted -- possible bug in isapi_redirector2.dll?
Date Mon, 02 Dec 2002 14:20:57 GMT
Hello,

We are trying to use Tomcat 4.1.12 with IIS 5.0. To all
appearance the configuration works perfectly.

However a serious error sometimes occurrs when we access tomcat
through IIS (I have not been able to reproduce this error using
tomcat directly without IIS).

However, in some cases large files get corrupted when
uploading--32 bytes of the file are taken from one location
and copied to a later place in the file. Typically the error
occurs the first time at appr. the 56,000th byte in the file.
If the file is very large, the same sequence of 32 bytes gets
copied several times later on in the file. The file is not
sent using chunked transfer-encoding.

The call finishes without errors, and there are no suspicious-
looking entries in the logs as far as I can tell (I have set
log_level=debug in the registry for the isapi filter). The size
of the produced file on the server is the same as the original,
but the same number of bytes that were erroneously copied are
missing at the end of the file. The next http call after this
happens always fails, as the bytes that should have been at the
end of the file seem to be left on the socket.

This error does not happen every time I upload a large file, but
usually once out of 2-5 tries.

I have tried to use versions 2.0.1 and 2.0.2 of isapi_redirector2.dll,
with the same result. Have anyone else experienced a similar problem?
Could this possibly be a configuration problem, or is it a bug in
the isapi_redirector filter?

I will appreciate any help on this.

Best Regards,
Joakim Strom
System Architect, Excosoft



--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message