tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Shankar Chelakarai" <schelaka...@audiopoint.net>
Subject RE: Tomcat 3.3.1 and jdk1.4
Date Thu, 26 Dec 2002 17:20:55 GMT
Ok I got it working.. my mistake .. for some reason never had a lib
directory inside java1.4 directory . It had the tools.jar file in it. Now it
works just fine.

-----Original Message-----
From: Shankar Chelakarai [mailto:schelakarai@audiopoint.net]
Sent: Thursday, December 26, 2002 12:05 PM
To: Tomcat Users List
Subject: Tomcat 3.3.1 and jdk1.4

Hi ,
       I have been fighting with this problem for quite sometime now. Can
anyone tell me what the problem could be.

I have jdk1.4 installed with tomcat 3.3.1 on a Unix box.
I have set the JAVA_HOME directory set to point to java1.4 .
And when I do java -fullversion I do get     java full version "1.4.0-b92"

Now I get this error when I try to run a jsp

org.apache.jasper.JasperException: Unable to compile error: Invalid class
file format in /usr/java1.4/jre/lib/rt.jar(java/lang/Object.class).  The
major.minor version '48.0' is too recent for this tool to understand.
/export/home/jakarta-tomcat-3.3.1/work/DEFAULT/vt/PopAvail_1.java:0: Class
java.lang.Object not found in class javax.servlet.GenericServlet.
import javax.servlet.*;
^
2 errors

        at
org.apache.tomcat.facade.JasperLiaison.javac(JspInterceptor.java:898)
        at
org.apache.tomcat.facade.JasperLiaison.processJspFile(JspInterceptor.java:73
3)
        at
org.apache.tomcat.facade.JspInterceptor.requestMap(JspInterceptor.java:506)
        at
org.apache.tomcat.core.ContextManager.processRequest(ContextManager.java:968
)
        at
org.apache.tomcat.core.ContextManager.internalService(ContextManager.java:87
5)
        at
org.apache.tomcat.core.ContextManager.service(ContextManager.java:833)
        at
org.apache.tomcat.modules.server.Http10Interceptor.processConnection(Http10I
nterceptor.java:176)
        at
org.apache.tomcat.util.net.TcpWorkerThread.runIt(PoolTcpEndpoint.java:494)
        at
org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.jav
a:516)
        at java.lang.Thread.run(Thread.java:536)


I made a few searched on the web and everyone say that its because of
version mismatch . I am not able to figure out where exactly I need to
change what.
One suggestion was to replace tools.jar but I don't see that jar file being
used by jdk1.4 at all. Any suggestions will be most welcome.

Thanks
Shankar


--
To unsubscribe, e-mail:
<mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail:
<mailto:tomcat-user-help@jakarta.apache.org>


--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message