tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Pooleery, Manoj" <Poole...@Synygy.com>
Subject RE: TC 4.1 and VM crash: how to report issue?
Date Tue, 10 Dec 2002 22:47:03 GMT
This looks more likely a memory issue to me.  Have you tried setting the
heap size for the JVM?  I had faced a similar problem earlier and it was
solved when I changed the heap memory settings.  Depending upon the server's
memory, you can use the '-Xmx xxk -Xms xxk' option to change your heap
settings.

-Manoj.

-----Original Message-----
From: Aymeric Alibert [mailto:AymericAlibert@alliantenergy.com]
Sent: Tuesday, December 10, 2002 5:38 PM
To: <
Subject: TC 4.1 and VM crash: how to report issue?


We are running a Tomcat 4.0 server in our production environment and
I am trying to upgrade to Tomcat 4.1.

I ran some load test recently and was horrified to see the server crashing
even
under moderate load. After more testing, I found that starting the VM with
the
-server option systematically crash the VM after few minutes of load test.
The server works fine even under heavy load with the -client option.
The same behavior can be reproduced with both JDK1.4.0 and JDK1.4.1.

My TC4.0 server runs fine with the -server option.

Now, this is obviously a JVM problem but probably won't have any help from 
SUN since:
- I cannot create a test case to reproduce my problem.
- I works fine with TC4.1

Can someone help me with this issue or at least guide me to the right
contact?
I found several tickets opened on the SUN bug database with similar issues
but
none of them had a resolution or people assigned to work on them.

Thanks!

Aymeric

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message