tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Shapira, Yoav" <Yoav.Shap...@mpi.com>
Subject RE: A dead cat
Date Fri, 06 Dec 2002 14:06:49 GMT
Howdy,
It is difficult to help specifically, but here are a couple of general
notes that may be relevant:

1. Tomcat won't die (actually, the JVM won't die) if you've created any
non-daemon threads in your application.  If you create such threads,
either set them as daemons or ensure their proper termination.

2. I suggest simplifying your deployment process, at least temporarily.
Don't use the manager to redeploy.  Copy the war file manually each
time.  Unless you have some special settings, don't enter a <Context>
element for your webapp in server.xml.  Restart tomcat, ensuring it's
dead, between each deployment.

If you could post more details, including OS name and version, tomcat
version, JDK version, your web.xml file, we could probably help more.

Yoav Shapira
Millennium ChemInformatics


>-----Original Message-----
>From: Simon Kelly [mailto:kelly@ipe.fzk.de]
>Sent: Friday, December 06, 2002 4:19 AM
>To: tomcat-user@jakarta.apache.org
>Subject: A dead cat
>
>Hi,
>
>I am currently using tomcat as a standalone server to test some webapps
>that
>I am creating.  I have some experiance with web servers but little or
no
>experiance with tomcat.  And I have a couple of major problems.
>
>1)  The cat is dead but won't go away!  I have installed tomcat twice
now,
>the first time I had a conflict within the port addressing for tomcat
and
>my
>exist database where both were configured to listen on the same port.
A
>school boy error really, but when I killed off tomcat and edited the
server
>config file to listen on an other port I got Exceptions every time I
tried
>to restart tomcat.  I uninstalled and then reinstalled tomcat and
>everything
>was working fine for a couple of days.  However! After problem 2
occured
>the
>same situation has come back with tomcat.  The one thing I have noticed
>though is that the tomcat.exe in the process list cannot be killed
using
>task manager.
>
>2)  When tomcat was up and running the second time I managed to get the
war
>file into the webapps dir and it automatically detected it, created a
>directory and deployed.  However, after a while and during one of the
>updates to the app, tomcat seemed to jam and would not reload the app.
I
>tryed to use the manager, but it would not let me even restart the app.
>So,
>I removed it from the directory and then restarted tomcat.  This time
>tomcat
>would not even see the file was there and I had to install it using
>manager.
>This worked for the first couple of changes, but then this too failed
and
>now tomcat will not respond at all.
>
>I am going to unistall and reinstall again, but if anyone knows why
this is
>going wrong I would be most greatful.
>
>As a side, during the deployment using manager I got the  app in by
>declaring the path '/katrin' and then giving the file url
>'file:/c:/programme/apache group/tomcat 4.1/webapps/katrin.war'.  This
>worked for a couple of times, but then failed.  There are a direct copy
of
>the last lines I entered.  Is there something I have done wrong in the
url,
>as it is this error "Mallformed url ..." that I am getting.
>
>Kindest regards
>
>Simon
>
>Institut fuer
>Prozessdatenverarbeitung
>und Elektronik,
>Forschungszentrum Karlsruhe GmbH,
>Postfach 3640,
>D-76021 Karlsruhe,
>Germany.
>
>Tel: (+49)/7247 82-4042
>E-mail : kelly@ipe.fzk.de
>
>
>--
>To unsubscribe, e-mail:   <mailto:tomcat-user-
>unsubscribe@jakarta.apache.org>
>For additional commands, e-mail: <mailto:tomcat-user-
>help@jakarta.apache.org>


--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message