tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ron Day" <ron...@ronday.cc>
Subject RE: javabean problems
Date Sun, 08 Dec 2002 17:00:05 GMT
Your javabeans are not in a package.Tomcat 4.xx does not like this as it
puts it in the default package, and then cannot find it at run time.

Just put your beans in a package, recompile and then add your package
directory structure under the "classes" directory.

i.e if you have com.my.package for a bean mybean.class, then
put mybean.class in webapps/WEB-INF/classes/com/my/package directory

R

-----Original Message-----
From: Mikael Gvransson [mailto:micke@debinary.net]
Sent: Sunday, December 08, 2002 8:48 AM
To: tomcat-user@jakarta.apache.org
Subject: javabean problems


hey,

it seems like i can't run my javabeans.
i'm using tomcat 4.1.12 binary distrubtion.

i get the error "cannot resolve symbol".

and i have no idea what it could be, it's just
a simple bean:

public class JellyBean implements java.io.Serializable {
	private String color;

	public JellyBean() {
	}

	public String getColor() {
		return color;
	}

	public void setColor(String newColor) {
		color = newColor;
	}
}


--
 _  _  . |   _   _  |   micke@debinary.net
| )( | | |< (_| (-` |   http://micke.debinary.net


--
To unsubscribe, e-mail:
<mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail:
<mailto:tomcat-user-help@jakarta.apache.org>


--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message