tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Schultz, Cecilia" <Schultz_Ceci...@rsccd.org>
Subject solved: RE: Tomcat and IIS
Date Wed, 04 Dec 2002 22:28:34 GMT

Just want to give a solution for any other user..
I was missing 

/i1440/*.jsp=ajp13
/i1440/servlet/*=ajp13

in uriworkermap.properties

after adding this and restarting tomcat, I started to see the 
80 GET /jakarta/isapi_redirect.dll - 200 Mozilla/4.0+(compatible;+MSIE+6.0;+Windows+NT+5.0)
entries in iis log

Thank you
Cecilia




> -----Original Message-----
> From: Schultz, Cecilia 
> Sent: Tuesday, December 03, 2002 9:01 AM
> To: Tomcat Users List
> Subject: Tomcat and IIS
> 
> 
> 
> 
> Hi,
> 
> I installed Tomcat 3.3.1, win2K server with IIS 
> 
> I followed the IIS HowTo and did all the additional IIS setup 
> to have IIS redirect jsp/servlets to tomcat (started tomcat 
> with jkconf option, generated the isapi_redirect.properties 
> files in conf/auto, created Jakarta virtual directory on 
> isapi_redirect.dll, restarted tomcat, etc)
> 
> 
> I have a simple test1.jsp with content:
> 
> <html>
> <body>
> <% String thispage="test1.jsp"; %>
> this page is <%=thispage %> 
> </body>
> </html>
> 
> 
> I am able to see a "this page is test1.jsp" when I do:
> 
> http://webapps2/examples/test1.jsp
> 
> http://webapps2/admin/test2.jsp
> 
> 
> but when I try to see it in the web app that I set up (which 
> is not not under c:\tomcat\webapps)
> I don't get to see the jsp part (I only see "this page is")
> 
> http://webapps2/i1440/test1.jsp
> 
> 
> "i1440" is a virtual directory that points to a directory 
> path F:\i1440root\opt\i1440\webapps\i1440
> 
> this directory has a WEB-INF under it, and a web.xml is 
> inside this WEB-INF directory.
> 
> At this point, the content of web.xml is very simple:
> 
> <?xml version="1.0" encoding="ISO-8859-1"?>
> <!DOCTYPE web-app
>     PUBLIC "-//Sun Microsystems, Inc.//DTD Web Application 2.2//EN"
>     "http://java.sun.com/j2ee/dtds/web-app_2_2.dtd">
> <web-app>
>    <description>JHU iTrack</description>
> </web-app>
> 
> 
> 
> 
> also, the content of c:\tomcat\conf\apps-i1440.xml is
> 
> 
> <?xml version="1.0" encoding="ISO-8859-1"?>
> <webapps>
>    <Context path="/i1440" 
>             docBase="F:/i1440root/opt/i1440/webapps/i1440" 
>             debug="0" 
>             trusted="true"
> 	        reloadable="true"> 
>   </Context>
> </webapps>
> 
> 
> 
> Why am I doing wrong? why am I not able to see a test1.jsp 
> under my i1440 web app? is tehre a restriction in Tomcat that 
> your webapp needs to be under c:\tomcat\webapps  ?
> 
> 
> Thanks in advance for your help
> Cecilia
> 
> 
> --
> To unsubscribe, e-mail:   
> <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
> For additional commands, e-mail: 
> <mailto:tomcat-user-help@jakarta.apache.org>
> 
> 

--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message