tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jerry Ford <>
Subject Re: another mod_jk attempt failing
Date Tue, 24 Dec 2002 23:20:06 GMT

I gave up trying to build it and retrieved a binary from your how-to site.  

But I can't make that work either.  I have gotten to the point where 
Tomcat appears to be starting up with ajp13 in working order.  At least, 
catalina.out reports ajp13 listening on port 8009, which I take to mean 
mod_jk is functional.

But Apache's error_log says it is unable to open the workers file (even 
though the file is in the location specified and I've tried every 
combination of permissions there are), and jk is not functional.  And 
servlets don't work.

As for compiling mod_jk using an absolute path to apxs, I just tried it, 
same results---fails on litconfig --no-verify.


Turner, John wrote:

>Have you tried using the full path to apxs instead of "../../../.." ?  I
>always use something like /usr/local/apache/bin/apxs.
>-----Original Message-----
>From: Jerry Ford [] 
>Sent: Friday, December 20, 2002 9:12 PM
>To: Tomcat Users List
>Subject: another mod_jk attempt failing
>When I try to build mod_jk from the source contained in 
>jakarta-tomcat-connectors-4.1.12-src.tar, the process breaks before it 
>gets started.
>I am following the instructions on John Turner's how-to page, but when I 
>run the configure script, it breaks at ltconfig---I get an error message 
>that says a host type must be specified when the --no-verify flag is used. 
>But running ltconfig --help shows no parameter for specifying host type, 
>and the command is run from the configure script anyway. 
>Can anyone tell me what's going on, and more importantly how do I 
>correct it?
>Here's the output when I run configure; the path to apxs is correct, and 
>JAVA_HOME points to a valid Java 1.4 JDK:
>[jford@gizmo native]$ ./configure 
>--with-apxs=../../../apache_1.3.27/bin/apxs --with-java-home=$JAVA_HOME
>checking for a BSD-compatible install... /usr/bin/install -c
>checking whether build environment is sane... yes
>checking whether make sets $(MAKE)... yes
>checking for working aclocal... found
>checking for working autoconf... found
>checking for working automake... found
>checking for working autoheader... found
>checking for working makeinfo... found
>checking build system type... i686-pc-linux-gnu
>checking host system type... i686-pc-linux-gnu
>checking for ranlib... ranlib
>checking for gcc... gcc
>checking for C compiler default output... a.out
>checking whether the C compiler works... yes
>checking whether we are cross compiling... no
>checking for suffix of executables...
>checking for suffix of object files... o
>checking whether we are using the GNU C compiler... yes
>checking whether gcc accepts -g... yes
>checking for gcc option to accept ANSI C... none needed
>checking for ld used by GCC... /usr/bin/ld
>checking if the linker (/usr/bin/ld) is GNU ld... yes
>checking for BSD-compatible nm... /usr/bin/nm -B
>checking whether ln -s works... yes
>ltconfig: you must specify a host type if you use `--no-verify'
>Try `ltconfig --help' for more information.
>configure: error: libtool configure failed
>[jford@gizmo native]$
>To unsubscribe, e-mail:
>For additional commands, e-mail:
>Incoming mail is certified Virus Free.
>Checked by AVG anti-virus system (
>Version: 6.0.419 / Virus Database: 235 - Release Date: 11/13/2002
>Outgoing mail is certified Virus Free.
>Checked by AVG anti-virus system (
>Version: 6.0.419 / Virus Database: 235 - Release Date: 11/13/2002
>To unsubscribe, e-mail:   <>
>For additional commands, e-mail: <>

To unsubscribe, e-mail:   <>
For additional commands, e-mail: <>

View raw message