tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joaquim <laurea...@comcast.net>
Subject Configuration problems with Tomcat 4.0.2 and Tomcat 4.1.12 ???
Date Tue, 10 Dec 2002 19:39:01 GMT
Hi,

I have Tomcat 4.0.2 and Tomcat 4.1.12 installed on the same server. The
application web.xml file is the same. The Tomcat's configuration file,
server.xml and web.xml, for as much as I can see, contain the same
confiured elements. The server is running behind a DFL300 firewall,
using a vitual IP address.  The server has port 80 forwarded to 8080.

Here is the problem.
If I enter http://mywebsiteIPorDNS, 4.1.12 delivers the welcome.jsp to
the browser without any problem, however, I have to add the port
(http://mywebsiteIPorDNS:80) for 4.0.2 to work. Without the port, 4.0.2
will cause the browser to give an error message saying "www.welcome.jsp
could not be found. ..."

On the other hand, while 4.0.2 works fine with the following code:

<% String avar = "dasdf"; %>
<jsp:plugin type="applet" ...
<jsp:params>
<jsp:param name="asd" value="<%=avar%>"/>
...........
...........

4.1.12 is unable to resolve the variable and the compiled servlet ends
up with "value=avar".

I would appreciate if anyone could help me undertand what I am missing.
Thank you.

-- 
Joaquim Laureano
Email: laureano8@comcast.net




--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message