tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From SAXESS - Hussayn Dabbous <dabb...@saxess.com>
Subject ajp13 port always 8009 (config does not apply)
Date Mon, 02 Dec 2002 15:26:34 GMT
Hy;

I wanted to change the ajp13 port from 8009 (the default port) to
9010. But i always see, the instance opening on the default port.
This is an exerpt of my server.xml:

<!-- Define a non-SSL Coyote HTTP/1.1 Connector on port 9000 -->
<Connector className="org.apache.coyote.tomcat4.CoyoteConnector"
     port="9000" minProcessors="5" maxProcessors="75"
     enableLookups="true" redirectPort="8443"
     acceptCount="10" debug="99" connectionTimeout="20000"
     useURIValidationHack="false" />

<!-- Define a Coyote/JK2 AJP 1.3 Connector on port 9010 -->
<Connector className="org.apache.coyote.tomcat4.CoyoteConnector"
     port="9010" minProcessors="5" maxProcessors="75"
     enableLookups="true" redirectPort="8443"
     acceptCount="10" debug="99" connectionTimeout="20000"
     useURIValidationHack="false"
     protocolHandlerClassName="org.apache.jk.server.JkCoyoteHandler"/>

I can connect from a browser via port 9000. And if i comment out the
ajp connector and restart tomcat, the ajp connector will not be
instanciated as expected. So i am shure, my server.xml is readable
and been executed...

I tried to track the problem within the sources, but i quickly gave up.
Maybe someone knows, if this is a bug (i've seen a NEW bug on this issue
in the bugdatabase) or i missunderstand something ...


regards, hussayn



--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message