tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Matt Small <msm...@Clickability.com>
Subject 4.1.17 Problems - Possibly Coyote Connector?
Date Wed, 18 Dec 2002 19:44:57 GMT
I have been trying out 4.1.17 in my development environment and it is giving
me much grief. When I first start the server everything works fine, but
after hitting my webapp a few times (say 10 to 20 times) it starts returning
blank pages. I have tried turning on all the logging I can to no avail. One
thing that I know for sure is that my application is being called and is
returning from Do Get properly. I do not have this problem with 4.1.12. We
rolled our dev environment back to 4.1.12 and everything is working fine
now. I suspect, but am not sure that the problem is in the connector. Can
anybody speculate on what the trouble might be? Thanks.

I first had this problem on a 4 proc RedHat Linux box with Kernel 2.4.18 rev
5.  We rolled that back to 4.1.12 so everyone here could work.  I was able
to reproduce the problem exactly on my Win2000 Server box.  In both cases I
am using the Coyote HTTP 1.1 connector.

View Source in IE gives this:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<HTML><HEAD>
<META content="text/html; charset=iso-8859-1"
http-equiv=Content-Type></HEAD>
<BODY></BODY></HTML>

My Server XML is very simple:

<Server port="8007" shutdown="SHUTDOWN" debug="0">

	<Logger className="org.apache.catalina.logger.FileLogger"
		directory="e:/logs" verbosity="3" prefix="server."
suffix=".log"
		timestamp="false"/>

	<Service name="Tomcat-Standalone">

		<Connector
className="org.apache.coyote.tomcat4.CoyoteConnector"
			port="80" minProcessors="2" maxProcessors="10"
			enableLookups="false" redirectPort="80"
			acceptCount="10" debug="0" connectionTimeout="60000"
			useURIValidationHack="false" />

		<Engine name="Standalone" defaultHost="myapp.azaghal.com"
debug="0">
			<Realm
className="org.apache.catalina.realm.JDBCRealm" debug="0"
				driverName="com.informix.jdbc.IfxDriver"
				connectionURL="xxxx"
				connectionName="xx" connectionPassword="xxx"

				userTable="User" userNameCol="userName"
userCredCol="password"
				userRoleTable="TomcatRole"
roleNameCol="role" />

			<Logger
className="org.apache.catalina.logger.FileLogger"
				directory="e:/logs" verbosity="3"
prefix="tomcat." suffix=".log"
				timestamp="false"/>

			<Host name="myapp.azaghal.com" debug="0"
appBase="webapps" liveDeploy="false" autoDeploy="false">
				<Valve
className="org.apache.catalina.valves.AccessLogValve"
					directory="e:/logs"
prefix="access." suffix=".log"
					pattern="common"/>
				<Logger
className="org.apache.catalina.logger.FileLogger"
					directory="e:/logs"  verbosity="3"
prefix="host." suffix=".log"
					timestamp="false"/>
				<Context path="/myapp"
docBase="e:/jakarta-tomcat-4.1.17/webapps/myapp" debug="0"
reloadable="false">
					<Manager pathname=""/>
					<Logger
className="org.apache.catalina.logger.FileLogger"
						directory="e:/logs"
verbosity="3" prefix="app." suffix=".log"
						timestamp="false"/>
				</Context>
			</Host>

--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message