tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sarah Grimley <sarahg...@yahoo.co.uk>
Subject RE: Advice please: Apache doesn't seem to resolve Tomcat symbolic links
Date Mon, 09 Dec 2002 16:59:28 GMT

Hi John,

I hope this is what you mean:

apache access_log:

170.237.230.231 - - 2002-12-09 17:55:53 0 "GET /seqreq/icons/seqwright.gif HTTP/1.1" 404 758
170.237.230.231 - - 2002-12-09 17:55:53 0 "GET /seqreq/icons/info9.gif HTTP/1.1" 404 746
170.237.230.231 - - 2002-12-09 17:55:53 0 "GET /seqreq/icons/w2_reset.gif HTTP/1.1" 404 755
170.237.230.231 - - 2002-12-09 17:55:53 0 "GET /seqreq/icons/w2_submit.gif HTTP/1.1" 404 758


 "Turner, John" <JTurner@AAS.com> wrote:
What do the Apache logs say for those requests?

John


> -----Original Message-----
> From: Sarah Grimley [mailto:sarahg_ml@yahoo.co.uk]
> Sent: Monday, December 09, 2002 10:51 AM
> To: Tomcat Users List
> Subject: Advice please: Apache doesn't seem to resolve Tomcat symbolic
> links
> 
> 
> 
> Inside my WEBAPP my subfolders 'ICONS' and 'TEMPLATES' are 
> actually symbolic links to folders elsewhere.
> I have enabled them to be accessed by my WebApp, by placing 
> this code inside the Tomcat server.xml:
> 
> > reloadable="true" crossContext="true">
> > prefix="MY_APP_log." suffix=".txt"
> timestamp="true"/>
> > ="org.apache.naming.resources.FileDirContext"
> allowLinking="true"/>
> 
> 
> I can then refer to gifs in my HTML as: <../icons/mypicture.gif>
> 
> This all works fine when I used Tomcat as standalone.
> 
> Now I want to use Apache with Tomcat as the webserver.
> 
> I configure Apache as follows:
> 
> 
> 
> WebAppConnection warpConnection warp localhost:8008
> WebAppDeploy examples warpConnection /examples/
> WebAppInfo /webapp-info
> 
> WebAppDeploy seqreq warpConnection /MY_APP/
> 
> 
> 
> I also include following in the Tomcat server.xml:
> 
> 
> 
> > className="org.apache.catalina.connector.warp.WarpConnector"
> port="8008" minProcessors="5" maxProcessors="75"
> enableLookups="true" appBase="webapps"
> acceptCount="10" debug="0"/>
> 
> > name="Apache" debug="0">
> 
> > prefix="apache_log." suffix=".txt"
> timestamp="true"/>
> 
> 
> 
> 
> 
> 
> 
> Now my problem is that the symbolic links no longer 
> resolve... so my gifs are not found. The rest of the files 
> can be accesses no problem, so I am sure it is because of the 
> 'virtual' links to the icon folder.
> 
> Can anybody help me to solve this problem? Thank you.
> 
> 
> 
> 
> ---------------------------------
> With Yahoo! Mail you can get a bigger mailbox -- choose a 
> size that fits your needs
> 

--
To unsubscribe, e-mail: 
For additional commands, e-mail: 




---------------------------------
With Yahoo! Mail you can get a bigger mailbox -- choose a size that fits your needs

Mime
  • Unnamed multipart/alternative (inline, 8-Bit, 0 bytes)
View raw message