tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Diego Sacchetto" <diegosacche...@attbi.com>
Subject creating a directory under webapps
Date Fri, 01 Nov 2002 15:57:54 GMT
Hi I've installed tomcat 4.1.12 and is running fine.
I can run all servlets under default directory
$CATALINA_HOME/webapps/examples.
Problem is if I create my own directory: diegodev under webapps.
I have created the usual structure, with a simple servlet under classes

        webapps
           |
           |
            --- diegodev
                    |
                    |
                     --- WEB-INF
                            |
                            |
                             --- classes
                            |       |
                            |       |
                            |        --- HelloWorld.class
                            |
                            |
                             --- web.xml

I have added the following element to server.xml:

<Context path="/diegodev" docBase="diegodev" debug="0" reloadable="true"/>

and the web.xml file has the <servlet> element like this:

<servlet>
   <servlet-name>HelloWorld</servlet-name>
   <servlet-class>HelloWorld</servlet-class>
</servlet>


Everything looks good to me but if I try to run the servlet by:

http://localhost:9000/diegodev/servlet/HelloWorld

tomcat complain it doesn't find the resource:

he requested resource (/diegodev/servlet/HelloWorld) is not available.

However, if I move the servlet under examples/WEB-INF/classes and I invoke
it, it works.

It looks like the directory examples has a setting that my custom directory
diegodev doesn't have.

Can't understand what it is.
Can please someone help me?

Thanks,

Diego.


--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message