tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Steinar Bang ...@dod.no>
Subject Re: HttpServletRequest.isSecure() fails with Coyote AJP 1.3 Connector
Date Thu, 07 Nov 2002 10:34:34 GMT
>>>>> "Bill Barker" <wbarker@wilshire.com>:

>> On Fri, 1 Nov 2002, Steinar Bang wrote:

>>> If I use the old AJP 1.3 connector, I can use the
>>> HttpServletRequest.isSecure() function to determine if the client
>>> used an HTTPS connection to the apache server.

>>> With the Coyote AJP 1.3 connector this information is lost.
>>> Ie. HttpServletRequest.isSecure() always returns false, and
>>> HttpServletRequest.getScheme() always returns "http".

> I believe that this is a bug, and has been fixed in 4.1.14 (and,
> even, 4.1.13 if you can run Tomcat without a sandbox).

Thanx for the info!  As far as I can tell, 4.1.12 is the latest
available version of tomcat, even counting nightly builds?

Do the 4.1.13 and 4.1.14 versions you refer to, exist as separate
branches in the CVS?  Or is 4.1.13 a branch, and 4.1.14-to-be HEAD?

Thanx!


- Steinar



--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message