tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ".: B i g D o g :." <big...@venticon.com>
Subject RE: Apache + Tomcat Installation
Date Fri, 08 Nov 2002 15:33:48 GMT
John,

You are probably going to shot my a*#...

Here is where i am at now...

I followed everything so far, when i start tomcat--all works--when i
start apache--great all works.

Now when i try and run the http://pclnxrhunter/examples/ i get
nothing...server error...

What know?


On Fri, 2002-11-08 at 22:18, Turner, John wrote:
> 
> That's your LoadModule line.  Apache needs to load mod_jk.so.  I've seen
> posts where the position of the LoadModule line is sensitive for some
> reason, nothing concrete.
> 
> I would verify 1) that you aren't loading mod_jk.so twice, as there is a
> LoadModule line for it in mod_jk.conf, and 2) that there is a LoadModule
> line for it in mod_jk.conf, and 3) that mod_jk.so is in the right location.
> 
> John
> 
> 
> > -----Original Message-----
> > From: .: B i g D o g :. [mailto:bigdog@venticon.com]
> > Sent: Friday, November 08, 2002 10:13 AM
> > To: Tomcat Users List
> > Subject: RE: Apache + Tomcat Installation
> > 
> > 
> > I so much appreciate all your hard work helping me out...
> > 
> > I have one problem and i know that i am almost there...
> > 
> > I did like you said with the listeners...
> > 
> > 
> > here is the new problem...
> > 
> > when I start up apache i get the following error:
> > 
> > Syntax error on line 28 of /usr/local/tomcat/conf/auto/mod_jk.conf:
> > Invalid command 'JkMount', perhaps mis-spelled or defined by a module
> > not included in the server configuration
> > /usr/local/apache/bin/apachectl start: httpd could not be started
> > 
> > What can i do now?
> > 
> > 
> > 
> > On Fri, 2002-11-08 at 22:04, Turner, John wrote:
> > > 
> > > The first one immediately after Server, the second one 
> > (with "forwardAll")
> > > immediately after Host.
> > > 
> > > John
> > > 
> > > 
> > > > -----Original Message-----
> > > > From: .: B i g D o g :. [mailto:bigdog@venticon.com]
> > > > Sent: Friday, November 08, 2002 10:00 AM
> > > > To: Tomcat Users List
> > > > Subject: RE: Apache + Tomcat Installation
> > > > 
> > > > 
> > > > And those listeners would be put in the server.xml file 
> > under <Server>
> > > > or <Server> and <Host>?
> > > > 
> > > > 
> > > > 
> > > > On Fri, 2002-11-08 at 21:53, Turner, John wrote:
> > > > > 
> > > > > Tomcat will only serve HTTP requests on the HTTP Connector, 
> > > > which defaults
> > > > > to 8080.  Port 8005 is the port for the Server element, it 
> > > > should be that
> > > > > way by default.
> > > > > 
> > > > > There is one Listener that calls ApacheConfig at the Server 
> > > > level, and one
> > > > > for each Host element, if you want to use AutoConfig.
> > > > > 
> > > > > "workersConfig" is a parameter to a Listener element.  If 
> > > > you want to be
> > > > > thorough, you would have two Listener elements, like this:
> > > > > 
> > > > > <Listener 
> > className="org.apache.ajp.tomcat4.config.ApacheConfig" 
> > > > > modJk="/your/path/to/apache/libexec-or-modules/mod_jk.so"
> > > > > workersConfig="/your/path/to/workers.properties" /> 
> > > > > 
> > > > > and one like this:
> > > > > 
> > > > > <Listener 
> > className="org.apache.ajp.tomcat4.config.ApacheConfig" 
> > > > > append="true" forwardAll="false" 
> > > > > modJk="/your/path/to/apache/libexec-or-modules/mod_jk.so"
> > > > > workersConfig="/your/path/to/workers.properties" /> 
> > > > > 
> > > > > John
> > > > > 
> > > > > 
> > > > > > -----Original Message-----
> > > > > > From: .: B i g D o g :. [mailto:bigdog@venticon.com]
> > > > > > Sent: Friday, November 08, 2002 9:43 AM
> > > > > > To: Tomcat Users List
> > > > > > Subject: RE: Apache + Tomcat Installation
> > > > > > 
> > > > > > 
> > > > > > I changed the port in the server.xml file...and that port 
> > > > > > does not work
> > > > > > when i try to access tomcat on it...
> > > > > > 
> > > > > > Where are the ApacheConfig Listener elements and the 
> > workersConfig
> > > > > > listener?
> > > > > > 
> > > > > > 
> > > > > > On Fri, 2002-11-08 at 21:40, Turner, John wrote:
> > > > > > > 
> > > > > > > I would add  
> > > > > > modJk="/your/path/to/apache/libexec-or-modules/mod_jk.so" to
> > > > > > > each of your ApacheConfig Listener elements.  
> > > > > > > 
> > > > > > > You could also add 
> > > > > > workersConfig="/your/path/to/workers.properties" to the
> > > > > > > same Listener elements.
> > > > > > > 
> > > > > > > Restart Tomcat and see what happens.  
> > > > > > > 
> > > > > > > When you say you changed the port to 8005, which port did 
> > > > > > you change?  It
> > > > > > > might not be necessary.
> > > > > > > 
> > > > > > > John
> > > > > > > 
> > > > > > > 
> > > > > > > > -----Original Message-----
> > > > > > > > From: .: B i g D o g :. [mailto:bigdog@venticon.com]
> > > > > > > > Sent: Friday, November 08, 2002 9:33 AM
> > > > > > > > To: Tomcat Users List
> > > > > > > > Subject: RE: Apache + Tomcat Installation
> > > > > > > > 
> > > > > > > > 
> > > > > > > > John,
> > > > > > > > 
> > > > > > > > Thank you again for your time and patience...it is much 
> > > > > > appreciated.
> > > > > > > > 
> > > > > > > > 
> > > > > > > > yep the permissions are all correct...
> > > > > > > > 
> > > > > > > > When i start tomcat this is what i get...
> > > > > > > > Using CATALINA_BASE:   /usr/local/tomcat
> > > > > > > > Using CATALINA_HOME:   /usr/local/tomcat
> > > > > > > > Using CATALINA_TMPDIR: /usr/local/tomcat/temp
> > > > > > > > Using JAVA_HOME:       /usr/local/java
> > > > > > > > 
> > > > > > > > And nothing in the conf directory.
> > > > > > > > 
> > > > > > > > I did change the port to 8005 like your tutorial.
> > > > > > > > 
> > > > > > > > Removed the catalina.out file.
> > > > > > > > Stopped and restarted Tomcat.
> > > > > > > > 
> > > > > > > > Now this is where i might need your help...this is the 
> > > > > > catalina.out
> > > > > > > > file:
> > > > > > > > 
> > > > > > > > [INFO] Registry - -Loading registry information
> > > > > > > > [INFO] Registry - -Creating new Registry instance
> > > > > > > > [INFO] Registry - -Creating MBeanServer
> > > > > > > > [INFO] Http11Protocol - -Initializing Coyote HTTP/1.1 
> > > > on port 8080
> > > > > > > > mod_jk location: libexec/mod_jk.so
> > > > > > > > Make sure it is installed corectly or  set the 
> > config location
> > > > > > > > Using <ApacheConfig modJk="PATH_TO_MOD_JK.SO_OR_DLL" />
> > > > > > > > Can't find workers.properties at
> > > > > > > > /usr/local/tomcat/conf/jk/workers.properties
> > > > > > > > Please install it in the default location or  set the 
> > > > > > config location
> > > > > > > > Using <ApacheConfig workersConfig="FULL_PATH" />
> > > > > > > > Starting service Tomcat-Standalone
> > > > > > > > Apache Tomcat/4.1.12
> > > > > > > > [INFO] Http11Protocol - -Starting Coyote HTTP/1.1 
> > on port 8080
> > > > > > > > [INFO] ChannelSocket - -JK2: ajp13 listening on 
> > tcp port 8009
> > > > > > > > [INFO] JkMain - -Jk running ID=0 time=1/13 
> > > > > > > > config=/usr/local/tomcat/conf/jk2.properties
> > > > > > > > 
> > > > > > > > 
> > > > > > > > 
> > > > > > > > On Fri, 2002-11-08 at 21:20, Turner, John wrote:
> > > > > > > > > 
> > > > > > > > > Strange.  Are permissions correct?  
> > > > > > > > > 
> > > > > > > > > John
> > > > > > > > > 
> > > > > > > > > 
> > > > > > > > > > -----Original Message-----
> > > > > > > > > > From: .: B i g D o g :. [mailto:bigdog@venticon.com]
> > > > > > > > > > Sent: Friday, November 08, 2002 9:12 AM
> > > > > > > > > > To: Tomcat Users List
> > > > > > > > > > Subject: RE: Apache + Tomcat Installation
> > > > > > > > > > 
> > > > > > > > > > 
> > > > > > > > > > That is the weird thing...i do not get the 
> > auto directory 
> > > > > > > > created...
> > > > > > > > > > 
> > > > > > > > > > 
> > > > > > > > > > On Fri, 2002-11-08 at 21:07, Turner, John wrote:
> > > > > > > > > > > 
> > > > > > > > > > > Looks just fine to me.  You should be getting a 
> > > > file called 
> > > > > > > > > > mod_jk.conf in
> > > > > > > > > > > $CATALINA_HOME/conf/auto.
> > > > > > > > > > > 
> > > > > > > > > > > John
> > > > > > > > > > > 
> > > > > > > > > > > 
> > > > > > > > > > > > -----Original Message-----
> > > > > > > > > > > > From: .: B i g D o g :. 
> > [mailto:bigdog@venticon.com]
> > > > > > > > > > > > Sent: Friday, November 08, 2002 9:04 AM
> > > > > > > > > > > > To: Tomcat Users List
> > > > > > > > > > > > Subject: RE: Apache + Tomcat Installation
> > > > > > > > > > > > 
> > > > > > > > > > > > 
> > > > > > > > > > > > Yep, I added all of those in step 3.
> > > > > > > > > > > > 
> > > > > > > > > > > > Here is what i have:
> > > > > > > > > > > > 
> > > > > > > > > > > > <Server 
> > > > > > className="org.apache.catalina.core.StandardServer" 
> > > > > > > > > > > > port="8080"
> > > > > > > > > > > > debug="9" shutdown="SHUTDOWN">
> > > > > > > > > > > > <Listener 
> > > > > > > > > > 
> > className="org.apache.ajp.tomcat4.config.ApacheConfig" /> 
> > > > > > > > > > > > <Listener 
> > > > > > > > > > > > 
> > > > > > className="org.apache.catalina.mbeans.ServerLifecycleListener"
> > > > > > > > > > > > debug="0"/>
> > > > > > > > > > > > <Listener
> > > > > > > > > > > > 
> > > > > > className="org.apache.catalina.mbeans.GlobalResourcesLifecycle
> > > > > > > > > > > > Listener"
> > > > > > > > > > > > debug="0"/>
> > > > > > > > > > > > 
> > > > > > > > > > > > Do I need all three?
> > > > > > > > > > > > 
> > > > > > > > > > > > 
> > > > > > > > > > > > 
> > > > > > > > > > > > Then for Host if have:
> > > > > > > > > > > > <Host 
> > > > className="org.apache.catalina.core.StandardHost"
> > > > > > > > > > > > appBase="webapps"
> > > > > > > > > > > > 
> > > > mapperClass="org.apache.catalina.core.StandardHostMapper"
> > > > > > > > > > > > liveDeploy="true" autoDeploy="true"
> > > > > > > > > > > > 
> > > > configClass="org.apache.catalina.startup.ContextConfig"
> > > > > > > > > > > > 
> > > > > > > > > > 
> > > > > > > > 
> > > > > > 
> > > > 
> > errorReportValveClass="org.apache.catalina.valves.ErrorReportValve"
> > > > > > > > > > > > debug="0" deployXML="true"
> > > > > > > > > > > > 
> > > > contextClass="org.apache.catalina.core.StandardContext"
> > > > > > > > > > > > unpackWARs="true" name="pclnxrhunter">
> > > > > > > > > > > >           <Listener
> > > > > > > > > > > > 
> > > > className="org.apache.ajp.tomcat4.config.ApacheConfig" 
> > > > > > > > > > append="true"
> > > > > > > > > > > > forwardAll="false" />  
> > > > > > > > > > > > 
> > > > > > > > > > > > 
> > > > > > > > > > > > The only difference is that i am running 
> > my tomcat on 
> > > > > > > > port 8080...
> > > > > > > > > > > > 
> > > > > > > > > > > > also i made sure that host name = httpd.conf 
> > > > ServerName...
> > > > > > > > > > > > 
> > > > > > > > > > > > I also check to make sure that i only have one 
> > > > > > Host section...
> > > > > > > > > > > > 
> > > > > > > > > > > > 
> > > > > > > > > > > > 
> > > > > > > > > > > > 
> > > > > > > > > > > > On Fri, 2002-11-08 at 20:58, Turner, John wrote:
> > > > > > > > > > > > > 
> > > > > > > > > > > > > Check Step 3 after building the 
> > connectors in the 
> > > > > > > > > > > > HOWTO....you have to stick
> > > > > > > > > > > > > a couple Listener elements into server.xml, one 
> > > > > > inside the 
> > > > > > > > > > > > Server container
> > > > > > > > > > > > > and one in the Host container (actually one in 
> > > > > > each Host 
> > > > > > > > > > > > container, but the
> > > > > > > > > > > > > default install only has one Host defined).
> > > > > > > > > > > > > 
> > > > > > > > > > > > > John
> > > > > > > > > > > > > 
> > > > > > > > > > > > > 
> > > > > > > > > > > > > > -----Original Message-----
> > > > > > > > > > > > > > From: .: B i g D o g :. 
> > > > [mailto:bigdog@venticon.com]
> > > > > > > > > > > > > > Sent: Friday, November 08, 2002 8:49 AM
> > > > > > > > > > > > > > To: Tomcat Users List
> > > > > > > > > > > > > > Subject: RE: Apache + Tomcat Installation
> > > > > > > > > > > > > > 
> > > > > > > > > > > > > > 
> > > > > > > > > > > > > > Thats fine...when i fire up tomcat, i do 
> > > > not get the 
> > > > > > > > > > mod_jk.conf
> > > > > > > > > > > > > > file...how, can i get tomcat to create that 
> > > > > > file for me?
> > > > > > > > > > > > > > 
> > > > > > > > > > > > > > Tomcat runs just great and i can run the 
> > > > examples and 
> > > > > > > > > > > > everything.  I
> > > > > > > > > > > > > > followed all the instructions from:
> > > > > > > > > > > > > > 
> > > > > > > > > > > > > > 
> > > > > > > > 
> > http://www.johnturner.com/howto/apache1-tomcat404-howto.html
> > > > > > > > > > > > > > 
> > > > > > > > > > > > > > the only problem is that when i start apache 
> > > > > > i get the 
> > > > > > > > > > > > > > following error:
> > > > > > > > > > > > > > 
> > > > > > > > > > > > > > fopen: No such file or directory
> > > > > > > > > > > > > > httpd: could not open document config file
> > > > > > > > > > > > > > /usr/local/tomcat/conf/auto/mod_jk.conf
> > > > > > > > > > > > > > /usr/local/apache/bin/apachectl start: 
> > > > httpd could 
> > > > > > > > > > not be started
> > > > > > > > > > > > > > 
> > > > > > > > > > > > > > 
> > > > > > > > > > > > > > On Fri, 2002-11-08 at 20:45, Turner, 
> > John wrote:
> > > > > > > > > > > > > > > 
> > > > > > > > > > > > > > > Not with mod_jk as I understand it. 
> >  You need 
> > > > > > > > mod_jk2 for 
> > > > > > > > > > > > > > that, which is a
> > > > > > > > > > > > > > > little different setup for the 
> > .properties file.
> > > > > > > > > > > > > > > 
> > > > > > > > > > > > > > > Unfortunately, I don't have any 
> > HOWTOs for JK2, 
> > > > > > > > as I don't 
> > > > > > > > > > > > > > use it (yet), but
> > > > > > > > > > > > > > > there are others out there, like 
> > this one from 
> > > > > > > > > > Robert Sowders:
> > > > > > > > > > > > > > > 
> > > > > > > > > > > > > > > 
> > > > > > > > > > > > > > 
> > > > > > > > > > > > 
> > > > > > > > > > 
> > > > > > > > 
> > > > > > 
> > > > 
> > ftp://pokey.wr.usgs.gov/pub/rsowders/Apache2_Jk2_TC4.1.x_JSDK1.4.x.zip
> > > > > > > > > > > > > > > 
> > > > > > > > > > > > > > > It's for Windows, but aside from 
> > the pathnames 
> > > > > > > > it should be 
> > > > > > > > > > > > > > just about
> > > > > > > > > > > > > > > identical.  You would also need to 
> > upgrade to 
> > > > > > > > Apache 2, I 
> > > > > > > > > > > > > > don't believe
> > > > > > > > > > > > > > > anyone has JK2 working with Apache 1.3, 
> > > > but I could 
> > > > > > > > > > be wrong.
> > > > > > > > > > > > > > > 
> > > > > > > > > > > > > > > John
> > > > > > > > > > > > > > > 
> > > > > > > > > > > > > > > 
> > > > > > > > > > > > > > > > -----Original Message-----
> > > > > > > > > > > > > > > > From: .: B i g D o g :. 
> > > > > > [mailto:bigdog@venticon.com]
> > > > > > > > > > > > > > > > Sent: Friday, November 08, 2002 8:30 AM
> > > > > > > > > > > > > > > > To: Tomcat Users List
> > > > > > > > > > > > > > > > Subject: RE: Apache + Tomcat Installation
> > > > > > > > > > > > > > > > 
> > > > > > > > > > > > > > > > 
> > > > > > > > > > > > > > > > John,
> > > > > > > > > > > > > > > > 
> > > > > > > > > > > > > > > > Thanks for all the help...
> > > > > > > > > > > > > > > > 
> > > > > > > > > > > > > > > > One question still remains...can 
> > Apache fire 
> > > > > > > > up tomcat so 
> > > > > > > > > > > > > > > > that i do not
> > > > > > > > > > > > > > > > have to start tomcat then apache?
> > > > > > > > > > > > > > > > 
> > > > > > > > > > > > > > > > 
> > > > > > > > > > > > > > > > 
> > > > > > > > > > > > > > > > On Fri, 2002-11-08 at 19:23, Turner, 
> > > > John wrote:
> > > > > > > > > > > > > > > > > 
> > > > > > > > > > > > > > > > > Pick yer poison:
> > > > > > > > > > > > > > > > > 
> > > > > > > > > > > > > > > > > http://www.johnturner.com/howto
> > > > > > > > > > > > > > > > > 
> > > > > > > > > > > > > > > > > You can skip most of 
> > it...you've got things 
> > > > > > > > > > installed and 
> > > > > > > > > > > > > > > > built.  That said,
> > > > > > > > > > > > > > > > > scroll down to the section 
> > after the gray 
> > > > > > > > "building the 
> > > > > > > > > > > > > > > > connectors" section
> > > > > > > > > > > > > > > > > and you'll see the exact steps 
> > > > needed to make 
> > > > > > > > > > > > > > > > http://localhost/examples work
> > > > > > > > > > > > > > > > > via Apache and mod_jk.  There 
> > aren't many.
> > > > > > > > > > > > > > > > > 
> > > > > > > > > > > > > > > > > You've got a lot going on in that 
> > > > > > > > workers.properties 
> > > > > > > > > > > > > > > > file...you don't need
> > > > > > > > > > > > > > > > > load-balancing at all unless you have 
> > > > > > > > multiple Tomcat 
> > > > > > > > > > > > > > > > instances, and you
> > > > > > > > > > > > > > > > > also don't need any ajp12 workers 
> > > > defined.  I 
> > > > > > > > > > also don't 
> > > > > > > > > > > > > > > > think you can do
> > > > > > > > > > > > > > > > > JNI at all from mod_jk, AFAIK you 
> > > > need mod_jk2 
> > > > > > > > > > for that. It 
> > > > > > > > > > > > > > > > might help
> > > > > > > > > > > > > > > > > things if you started with a 
> > plain vanilla 
> > > > > > > > > > > > > > > > workers.properties file, and went
> > > > > > > > > > > > > > > > > from there.  Something like:
> > > > > > > > > > > > > > > > > 
> > > > > > > > > > > > > > > > > worker.list=worker2
> > > > > > > > > > > > > > > > > worker.worker2.type=ajp13
> > > > > > > > > > > > > > > > > worker.worker2.host=localhost
> > > > > > > > > > > > > > > > > worker.worker2.port=8009
> > > > > > > > > > > > > > > > > 
> > > > > > > > > > > > > > > > > ...is all you need to get started.
> > > > > > > > > > > > > > > > > 
> > > > > > > > > > > > > > > > > John
> > > > > > > > > > > > > > > > > 
> > > > > > > > > > > > > > > > > > -----Original Message-----
> > > > > > > > > > > > > > > > > > From: .: B i g D o g :. 
> > > > > > > > [mailto:bigdog@venticon.com]
> > > > > > > > > > > > > > > > > > Sent: Friday, November 08, 
> > 2002 6:38 AM
> > > > > > > > > > > > > > > > > > To: tomcat-user@jakarta.apache.org
> > > > > > > > > > > > > > > > > > Subject: Apache + Tomcat Installation
> > > > > > > > > > > > > > > > > > 
> > > > > > > > > > > > > > > > > > 
> > > > > > > > > > > > > > > > > > All,
> > > > > > > > > > > > > > > > > > 
> > > > > > > > > > > > > > > > > > I have some questions concerning the 
> > > > > > mod_jk for 
> > > > > > > > > > > > apache and 
> > > > > > > > > > > > > > > > > > getting it to
> > > > > > > > > > > > > > > > > > run.
> > > > > > > > > > > > > > > > > > 
> > > > > > > > > > > > > > > > > > I moved all the examples for 
> > tomcat into 
> > > > > > > > my web root 
> > > > > > > > > > > > > > > > > > directory and when
> > > > > > > > > > > > > > > > > > i run the examples i get a 404 error 
> > > > > > from tomcat.
> > > > > > > > > > > > > > > > > > 
> > > > > > > > > > > > > > > > > > What can i do to solve this 
> > problem?  Any 
> > > > > > > > > > good docs out 
> > > > > > > > > > > > > > > > there...I have
> > > > > > > > > > > > > > > > > > mulled over apache.org.
> > > > > > > > > > > > > > > > > > 
> > > > > > > > > > > > > > > > > > 
> > > > > > > > > > > > > > > > > > Thanks,
> > > > > > > > > > > > > > > > > > 
> > > > > > > > > > > > > > > > > > [Info]
> > > > > > > > > > > > > > > > > > RedHat 7.3
> > > > > > > > > > > > > > > > > > Apache 1.3.26 (source)
> > > > > > > > > > > > > > > > > > Tomcat 4.1.12 (binary)
> > > > > > > > > > > > > > > > > > mod_jk.so     (mod_jk-1.3-noeapi.so - 
> > > > > > renamed to 
> > > > > > > > > > > > mod_jk.so)
> > > > > > > > > > > > > > > > > > 
> > > > > > > > > > > > > > > > > > 
> > > > > > > > > > > > > > > > > > [http.conf]
> > > > > > > > > > > > > > > > > > LoadModule jk_module libexec/mod_jk.so
> > > > > > > > > > > > > > > > > > <IfModule mod_jk.c>
> > > > > > > > > > > > > > > > > > JkWorkersFile 
> > > > > > > > > > /usr/local/tomcat/conf/workers.properties
> > > > > > > > > > > > > > > > > > JkLogFile 
> > > > /usr/local/tomcat/logs/mod_jk.log
> > > > > > > > > > > > > > > > > > JkLogLevel info
> > > > > > > > > > > > > > > > > > JkLogStampFormat "[%a %b %d 
> > %H:%M:%S %Y] "
> > > > > > > > > > > > > > > > > > JkRequestLogFormat "%w %V %T"
> > > > > > > > > > > > > > > > > > JkMount /*.jsp worker2
> > > > > > > > > > > > > > > > > > </IfModule>
> > > > > > > > > > > > > > > > > > 
> > > > > > > > > > > > > > > > > > 
> > > > > > > > > > > > > > > > > > [tomcat's workers.properties]
> > > > > > > > > > > > > > > > > > # Define some properties
> > > > > > > > > > > > > > > > > > 
> > > > > > > > workers.apache_log=/usr/local/apache/logs/error_log
> > > > > > > > > > > > > > > > > > workers.tomcat_home=/usr/local/tomcat
> > > > > > > > > > > > > > > > > > workers.java_home=/usr/local/java
> > > > > > > > > > > > > > > > > > ps=/
> > > > > > > > > > > > > > > > > > 
> > > > > > > > > > > > > > > > > > # Define 4 workers, 3 real workers 
> > > > > > using ajp12, 
> > > > > > > > > > > > ajp13, jni, 
> > > > > > > > > > > > > > > > > > the last one
> > > > > > > > > > > > > > > > > > being a loadbalancing worker
> > > > > > > > > > > > > > > > > > worker.list=worker1, worker2, 
> > > > worker3, worker4
> > > > > > > > > > > > > > > > > > 
> > > > > > > > > > > > > > > > > > # Set properties for worker1 (ajp12)
> > > > > > > > > > > > > > > > > > worker.worker1.type=ajp12
> > > > > > > > > > > > > > > > > > worker.worker1.host=localhost
> > > > > > > > > > > > > > > > > > worker.worker1.port=8007
> > > > > > > > > > > > > > > > > > worker.worker1.lbfactor=5
> > > > > > > > > > > > > > > > > > 
> > > > > > > > > > > > > > > > > > # Set properties for worker2 (ajp13)
> > > > > > > > > > > > > > > > > > worker.worker2.type=ajp13
> > > > > > > > > > > > > > > > > > worker.worker2.host=localhost
> > > > > > > > > > > > > > > > > > worker.worker2.port=8009
> > > > > > > > > > > > > > > > > > worker.worker2.lbfactor=50
> > > > > > > > > > > > > > > > > > worker.worker2.cachesize=10
> > > > > > > > > > > > > > > > > > worker.worker2.cache_timeout=600
> > > > > > > > > > > > > > > > > > worker.worker2.socket_keepalive=1
> > > > > > > > > > > > > > > > > > worker.worker2.socket_timeout=300
> > > > > > > > > > > > > > > > > > 
> > > > > > > > > > > > > > > > > > # Set properties for worker3 (jni)
> > > > > > > > > > > > > > > > > > #worker.worker3.type=jni
> > > > > > > > > > > > > > > > > > 
> > > > > > > > > > > > > > > > > > # Set worker3 classpath
> > > > > > > > > > > > > > > > > > 
> > > > > > > > > > > > 
> > > > > > #worker.worker3.class_path=$(workers.tomcat_home)$(ps)classes
> > > > > > > > > > > > > > > > > > 
> > > > > > > > > > > > 
> > > > > > #worker.worker3.class_path=$(workers.tomcat_home)$(ps)lib$(ps)
> > > > > > > > > > > > > > > > > > tomcat.jar
> > > > > > > > > > > > > > > > > > 
> > > > > > > > > > > > > > > > > > # Set worker3 tomcat command line
> > > > > > > > > > > > > > > > > > #worker.worker3.cmd_line=-home
> > > > > > > > > > > > > > > > > > 
> > > > > > #worker.worker3.cmd_line=$(workers.tomcat_home)
> > > > > > > > > > > > > > > > > > 
> > > > > > > > > > > > > > > > > > # Set worker3 Tomcat/JVM settings
> > > > > > > > > > > > > > > > > > 
> > > > > > > > > > > > 
> > > > > > #worker.worker3.jvm_lib=$(workers.java_home)$(ps)jre$(ps)bin$(
> > > > > > > > > > > > > > > > > > ps)classic$(ps)libjvm.so
> > > > > > > > > > > > > > > > > > 
> > > > > > > > > > > > > > 
> > > > > > > > > > 
> > > > > > 
> > #worker.worker3.stdout=$(workers.apache_log)$(ps)inprocess.stdout
> > > > > > > > > > > > > > > > > > 
> > > > > > > > > > > > > > 
> > > > > > > > > > 
> > > > > > 
> > #worker.worker3.stderr=$(workers.apache_log)$(ps)inprocess.stderr
> > > > > > > > > > > > > > > > > > 
> > > > > > > > > > > > 
> > > > > > #worker.worker3.sysprops=tomcat.home=$(workers.tomcat_home)
> > > > > > > > > > > > > > > > > > 
> > > > > > > > > > > > > > > > > > # Set properties for worker4 
> > (lb) which 
> > > > > > > > use worker1 
> > > > > > > > > > > > > > and worker2
> > > > > > > > > > > > > > > > > > 
> > > > > > #worker.worker4.balanced_workers=worker1,worker2 
> > > > > > > > > > > > > > > > > > 
> > > > > > > > > > > > > > > > > > 
> > > > > > > > > > > > > > > > > > -- 
> > > > > > > > > > > > > > > > > > .: B i g D o g :.
> > > > > > > > > > > > > > > > > > 
> > > > > > > > > > > > > > > > > > 
> > > > > > > > > > > > > > > > > > 
> > > > > > > > > > > > > > > > > > --
> > > > > > > > > > > > > > > > > > To unsubscribe, e-mail:   
> > > > > > > > > > > > > > > > > 
> > > > > > <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
> > > > > > > > > > > > > > > > > For additional commands, e-mail:
> > > > > > > > > > > > > > > > > 
> > <mailto:tomcat-user-help@jakarta.apache.org>
> > > > > > > > > > > > > > > > > 
> > > > > > > > > > > > > > > > > --
> > > > > > > > > > > > > > > > > To unsubscribe, e-mail:   
> > > > > > > > > > > > > > > 
> > > > <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
> > > > > > > > > > > > > > > > For additional commands, e-mail:
> > > > > > > > > > > > > > > <mailto:tomcat-user-help@jakarta.apache.org>
> > > > > > > > > > > > > > > -- 
> > > > > > > > > > > > > > > .: B i g D o g :.
> > > > > > > > > > > > > > > 
> > > > > > > > > > > > > > > 
> > > > > > > > > > > > > > > 
> > > > > > > > > > > > > > > --
> > > > > > > > > > > > > > > To unsubscribe, e-mail:
> > > > > > > > > > > > > > > 
> > > > <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
> > > > > > > > > > > > > > > For additional commands, e-mail:
> > > > > > > > > > > > > > > <mailto:tomcat-user-help@jakarta.apache.org>
> > > > > > > > > > > > > > > 
> > > > > > > > > > > > > > > --
> > > > > > > > > > > > > > > To unsubscribe, e-mail:   
> > > > > > > > > > > > > 
> > <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
> > > > > > > > > > > > > > For additional commands, e-mail:
> > > > > > > > > > > > > <mailto:tomcat-user-help@jakarta.apache.org>
> > > > > > > > > > > > > -- 
> > > > > > > > > > > > > .: B i g D o g :.
> > > > > > > > > > > > > 
> > > > > > > > > > > > > 
> > > > > > > > > > > > > 
> > > > > > > > > > > > > --
> > > > > > > > > > > > > To unsubscribe, e-mail:
> > > > > > > > > > > > > 
> > <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
> > > > > > > > > > > > > For additional commands, e-mail:
> > > > > > > > > > > > > <mailto:tomcat-user-help@jakarta.apache.org>
> > > > > > > > > > > > > 
> > > > > > > > > > > > > --
> > > > > > > > > > > > > To unsubscribe, e-mail:   
> > > > > > > > > > > <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
> > > > > > > > > > > > For additional commands, e-mail:
> > > > > > > > > > > <mailto:tomcat-user-help@jakarta.apache.org>
> > > > > > > > > > > -- 
> > > > > > > > > > > .: B i g D o g :.
> > > > > > > > > > > 
> > > > > > > > > > > 
> > > > > > > > > > > 
> > > > > > > > > > > --
> > > > > > > > > > > To unsubscribe, e-mail:
> > > > > > > > > > > <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
> > > > > > > > > > > For additional commands, e-mail:
> > > > > > > > > > > <mailto:tomcat-user-help@jakarta.apache.org>
> > > > > > > > > > > 
> > > > > > > > > > > --
> > > > > > > > > > > To unsubscribe, e-mail:   
> > > > > > > > > <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
> > > > > > > > > > For additional commands, e-mail:
> > > > > > > > > <mailto:tomcat-user-help@jakarta.apache.org>
> > > > > > > > > -- 
> > > > > > > > > .: B i g D o g :.
> > > > > > > > > 
> > > > > > > > > 
> > > > > > > > > 
> > > > > > > > > --
> > > > > > > > > To unsubscribe, e-mail:
> > > > > > > > > <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
> > > > > > > > > For additional commands, e-mail:
> > > > > > > > > <mailto:tomcat-user-help@jakarta.apache.org>
> > > > > > > > > 
> > > > > > > > > --
> > > > > > > > > To unsubscribe, e-mail:   
> > > > > > > <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
> > > > > > > > For additional commands, e-mail:
> > > > > > > <mailto:tomcat-user-help@jakarta.apache.org>
> > > > > > > -- 
> > > > > > > .: B i g D o g :.
> > > > > > > 
> > > > > > > 
> > > > > > > 
> > > > > > > --
> > > > > > > To unsubscribe, e-mail:
> > > > > > > <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
> > > > > > > For additional commands, e-mail:
> > > > > > > <mailto:tomcat-user-help@jakarta.apache.org>
> > > > > > > 
> > > > > > > --
> > > > > > > To unsubscribe, e-mail:   
> > > > > <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
> > > > > > For additional commands, e-mail:
> > > > > <mailto:tomcat-user-help@jakarta.apache.org>
> > > > > -- 
> > > > > .: B i g D o g :.
> > > > > 
> > > > > 
> > > > > 
> > > > > --
> > > > > To unsubscribe, e-mail:
> > > > > <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
> > > > > For additional commands, e-mail:
> > > > > <mailto:tomcat-user-help@jakarta.apache.org>
> > > > > 
> > > > > --
> > > > > To unsubscribe, e-mail:   
> > > <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
> > > > For additional commands, e-mail:
> > > <mailto:tomcat-user-help@jakarta.apache.org>
> > > -- 
> > > .: B i g D o g :.
> > > 
> > > 
> > > 
> > > --
> > > To unsubscribe, e-mail:
> > > <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
> > > For additional commands, e-mail:
> > > <mailto:tomcat-user-help@jakarta.apache.org>
> > > 
> > > --
> > > To unsubscribe, e-mail:   
> <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
> > For additional commands, e-mail:
> <mailto:tomcat-user-help@jakarta.apache.org>
> -- 
> .: B i g D o g :.
> 
> 
> 
> --
> To unsubscribe, e-mail:
> <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
> For additional commands, e-mail:
> <mailto:tomcat-user-help@jakarta.apache.org>
> 
> --
> To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
> For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>
-- 
.: B i g D o g :.



--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message