tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "pkrishnaswami" <pkris...@learnframe.com>
Subject RE: The disappearing classpath
Date Fri, 01 Nov 2002 20:38:11 GMT
Could you try putting it in shared\lib and see if it works?

Prabhakar

-----Original Message-----
From: Eric Hansen [mailto:ehansen@mmisoft.com]
Sent: Friday, November 01, 2002 1:27 PM
To: tomcat-user@jakarta.apache.org
Subject: The disappearing classpath


I having trouble with Tomcat 4.0.x Tomcat when deploying a war file.... I'm
getting classdefnotfound exceptions in my web app.

It turns out that this happens only when I am using jar files that are
external to the WEB-INF/lib (ie. in the [tomcat_home]/common/lib directory)
and so it seems that Tomcat stops looking for classes in the WEB-INF/lib
once it uses the external library - because as soon as I put all all the
required libs inside the WEB-INF/lib path, the web app works fine.

However, I have classes that are needed for multiple apps I would like to
deploy the jar in only one place. Can anyone explain to me how I can use
classes in a jar file from the external lib and still have access to my
WEB-INF/lib jars too???

Thanks,
-Eric


--
To unsubscribe, e-mail:
<mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail:
<mailto:tomcat-user-help@jakarta.apache.org>



--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message