tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From psalazar <pedro-b-sala...@ptinovacao.pt>
Subject tomcat4+jdk1.4.1+security providers
Date Mon, 21 Oct 2002 10:55:07 GMT
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Greetings,

I'm trying to use the security packages that are supported in jdk1.4 (no 
need of JCE now) in tomcat environment.

In a test environment running a class test in a shell, I can access a DES 
algorithm and use cipher/decipher methods. But when I'm using my class in 
tomcat (catalina), I'm getting this error:

java.security.NoSuchAlgorithmException: Cannot find any provider 
supporting DES

Why? I'm using the same jvm in both contexts but unfortunately tomcat is
blocking in somw way the access to the java.security providers. I'm not
using the -security flag in catalina (but I already tried with no
success).

Thanks,
Pedro Salazar.

- -- 
pedro salazar (pt-inovacao) <pedro-b-salazar@ptinovacao.pt>

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.0.6 (GNU/Linux)
Comment: For info see http://www.gnupg.org

iD8DBQE9s90PDhKeMdgDvGERAjSLAKCJ38Bt6dSzMtChSEfl5X1kDkIycACffQVJ
AmSVOJLRgfV3r1fwzqnsS6E=
=4sF3
-----END PGP SIGNATURE-----


--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message