tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alexander Piavka <pia...@cs.bgu.ac.il>
Subject re: symbolic linking
Date Tue, 22 Oct 2002 19:11:29 GMT

 This is the same problem i had and the patched solved it( i did not had to
add allowlinking to the server.xml file)
I just tried the same scenario you had mentioned beneath.
I made symbolic link to class
${TOMCAT_HOME}/home/sys/jsp/WEB-INF/classes/Test.class -> ~piavka/servlets/Test.class
and it works. I works also then i copy the Test.class instead of
linking(which obviously should)

 Are you shure you aplied the patch properly?
 If you want i can send you my patched ${TOMCAT_HOME}/common/lib/naming-resources.jar

> Even the patch doesn't fix my problem. I guess I have not explained my
> problem clearly. To be clear, I do not have my context outside
> ${TOMCAT_HOME}/webapps. But ${TOMCAT_HOME}/webapps/stuff/WEB-INF/classes
> directory is a symbolic link. My problem is, the classes underneath this
> symbolic link are not getting loaded. Tomcat simply spews out
> ClassNotFoundException while trying to deploy my servlet context. So the
> question is should I be updating server.xml(which I tried unsuccessfully)
> or is there a way to use allowLinking="true" in web.xml?
>
> Thanks very much for the help,
> Ganesh.
>
>
>
>
>
> "Alexander Piavka" <piavka@cs.bgu.ac.il>
>
> 22-Oct-2002 09:05
> Please respond to "Tomcat Users List" <tomcat-user@jakarta.apache.org>
>
>
>
>
>         To:     tomcat-user
>
>         cc:
>         Subject:        re: symbolic linking
>
>
>  Here is the patch i got from Torsten Fohrer
> that solves the bug with symbolic linking in 4.1.12
>
> ---------- Forwarded message ----------
> Date: Thu, 17 Oct 2002 17:16:14 +0200
> From: Torsten Fohrer <Torsten.Fohrer@dcsi.de>
> To: 'Alexander Piavka' <piavka@cs.bgu.ac.il>
> Subject: AW: tomcat 4.1 does not resolve links
>
>
> Here is patch for FileDirContext.java
>
> > -----Ursprüngliche Nachricht-----
> > Von: Alexander Piavka [mailto:piavka@cs.bgu.ac.il]
> > Gesendet: Donnerstag, 17. Oktober 2002 11:17
> > An: Tomcat Users List
> > Betreff: Re: tomcat 4.1 does not resolve links
> >
> >
> >
> >  Does anyone know then the  4.1.13 version will be released,
> > or maybe this
> > bug has been already solved and i can download the current
> > cvs(or a patch)?
> > Since i really need it urgently.
> > I tried to make minor changes in the FileDirContext.java file, so that
> > allowLinking is always enabled but it did now work.
> >
> >  Thanks.
> >
> > On Sun, 6 Oct 2002, Remy Maucherat wrote:
> >
> > > Alexander Piavka wrote:
> > > >  The RELEASE-NOTES it is said that to enable symbloic
> > linking i need to
> > > > add the allowLinking option to FileDirContext. But i did
> > not find anything
> > > > about FileDirContext in the documentation.
> > > > Does anyone know where  sould the FileDirContext
> > configuration be put
> > > > and where is the documentation about it.
> > >
> > > It turns out there is a bug in the feature in 4.1.12. It
> > will be fixed
> > > in 4.1.13, and properly documented.
> >
> --
> To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
> For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>
>


--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message