tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Milt Epstein <mepst...@uiuc.edu>
Subject Re: Apache/2 and Tomcat/4 not talking
Date Wed, 23 Oct 2002 00:05:59 GMT
On Tue, 22 Oct 2002, Jim Urban wrote:

> I have spent the past two days trying to get Apache/2 to forward servlet
> requests to Tomcat.  Here are the particulars:
>
> Java 1.3.0
> Win 2K SP3
> Tomcat 4.0.4
> Apache/2 0.43
> AJP13
> SSL
>
> Mod_jk.conf
> ########## Auto generated on Tue Oct 22 12:01:16 CDT 2002##########
>
> <IfModule !mod_jk.c>
>   LoadModule jk_module modules/mod_jk.dll
> </IfModule>
>
> JkWorkersFile "y:/Tomcat4.0.4/conf/jk/workers.properties"
> JkLogFile "y:/Tomcat4.0.4/logs/mod_jk.log"
>
> JkLogLevel debug
> JkLogStampFormat "[%a %b %d %H:%M:%S %Y] "
[ ... ]

You don't have any JkMount directives.  JkMount directives are of the
form:

JkMount url-pattern worker-name

They tell Apache what URL's (based on a match of the URL pattern) to
forward to Tomcat.  worker-name should be defined in
workers.properties with a number of:

worker.worker-name.property=value

where property is { host, port, type }.

Milt Epstein
Research Programmer
Integration and Software Engineering (ISE)
Campus Information Technologies and Educational Services (CITES)
University of Illinois at Urbana-Champaign (UIUC)
mepstein@uiuc.edu


--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message