tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From brendan.richa...@draftlondon.com
Subject Database Issues
Date Tue, 22 Oct 2002 15:12:22 GMT
Apologies in advance for posting a repeat of earlier messages but I've yet 
to come across a solution to my problem...

I'm attempting to get jetspeed working with PostgreSQL.
Following initial abortive attempts, I've installed the latest versions of 
both Tomcat (4.1.12) and Postgresql(7.2.3) to ensure I have clean builds 
but the issue remains.

The error when starting jetspeed is:

Horrible Exception: java.lang.Error: Error in 
BasePeer.initTableSchema(TURBINE_USER): Connection object is null!
                 at 
org.apache.jetspeed.om.security.turbine.BaseTurbineUserPeer.initClass(BaseTurbineUserPeer.java:145)
                 at 
org.apache.jetspeed.om.security.turbine.BaseTurbineUserPeer.<clinit>(BaseTurbineUserPeer.java:124)

..etc...



my torque.properties file looks like this:

database.default=jetspeed

database.default.driver=org.postgresql.Driver
database.default.url=jdbc:postgresql://localhost/jetspeed
database.default.username=jetspeed
database.default.password=



with a jetspeed database setup from the scripts provided and pjdbc2.jar 
intsalled in the lib directory from jdbc.postgresql.org



I've seen people with similar errors using both postgreSQL and mySQL.

I've also tried removing hsql.jar from the lib directory to make sure 
there is no classname clash between the hsql and postgres jdbc jars.


Any Ideas??


Brendan Richards
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message