tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From <Ganesh.K....@gsk.com>
Subject Re: Symbolic Link
Date Tue, 22 Oct 2002 12:56:37 GMT
It does. But I simply couldn't hold of the details listing how and where I
am suppose to use this attribute. I did try the following in server.xml
without much success,

<Context path="/stuff" docBase="stuff" debug="0" reloadable="true"
crossContext="false">
     <Resources className="org.apache.naming.resources.FileDirContext"
                    caseSensitive="false"
                    docBase=""
                    allowLinking="true"/>
</Context>

With the above lines in server.xml, tomcat startup fails with a message "
${TOMCAT_HOME}/stuff does not exist" which means tomcat is trying to deploy
a webapp  which is residing outside ${TOMCAT_HOME}/webapps which is not I
am trying to accomplish.

I am kinda stranded!!!
Ganesh


                                                                                         
                    
                    "Tobias Höglund"                                                    
                     
                    <tobiash@interia.se>                                           
                          
                                                                                         
                    
                                                 To:     "Tomcat Users List"             
                    
                    22-Oct-2002 08:43                                                    
                    
                    Please respond to            cc:                                     
                    
                    "Tomcat Users List"          Subject:     Re: Symbolic Link          
                    
                    <tomcat-user@jakarta.a                                            
                       
                    pache.org>                                                        
                       
                                                                                         
                    
                                                                                         
                    



Hi

In my  /usr/local/tomcat/jakarta-tomcat-4.1.12/RELEASE-NOTES-4.1.txt file I
found the
  below:

---------------------------
Symlinking static resources:
---------------------------

Unix symlinks will not work when used in a web application to link
resources
located outside the web application root directory.

This behavior is optional, and the "allowLinking" flag may be used to
disable
the check.

------------------------------

Does this explain your problem?
/Tobias

Ganesh.K.Rao@gsk.com wrote:
> Hi All,
>
>         Tomcat4 does not load classes under WEB-INF/classes/com/.... if
> com is a symbolic link to some other directory. This was not the case
with
> Tomcat3!!!!!. Please let me know if there is work around other than
> maintaining a physical directory under WEB-INF/classes.
>
> Thanks in advance,
> Ganesh



--
To unsubscribe, e-mail:   <
mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <
mailto:tomcat-user-help@jakarta.apache.org>







--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message