tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael Schulz" <m...@mschulz.net>
Subject RE: Chicken and the egg
Date Sun, 06 Oct 2002 01:11:42 GMT
Tomcat 4.1.x does support mod_jk as well as mod_jk2.  You just have to
enable the correct connector in your server.xml file.

In fact, I would claim that if you are currently using Tomcat 4.0.4 in
production, I would not upgrade to 4.1.x (yet) -- I would use 4.0.5 instead.
There have been enough people with issues regarding Tomcat 4.1.x that I
would wait on that unless there is something in there that you absolutely
need.

-Mike Schulz


-----Original Message-----
From: Michael Riess [mailto:sdemr@selltec.de]
Sent: Saturday, October 05, 2002 11:52 AM
To: tomcat-user@jakarta.apache.org
Subject: Chicken and the egg


Hi there,

Situation: I built a working configuration of Apache 2.0.35, Tomcat 4.0.4
and mod_jk, now I want to update my system.

I downloaded Apache 2.0.43, downloaded mod_jk2 binary ... just for 2.0.42,
so I downloaded the source ... libtool doesn't know -lapr ... tried to
default to mod_jk ... Tomcat 4.1.12 seems to support jk2 ONLY ... so now I'm
stuck.

Does anybody know a HOWTO that covers the two basic steps:
1. Integrate mod_jk2 in Apache 2.0
2. Get Tomcat to use jk2 (apparently this is the easier job ;-))


Sorry, the procedure is VERY complicated for users who don't do this
everyday. Actually, it is complicated because no documentation exists AND
the binary builds of Apache/jk/jk2 are NEVER compatible.



--
To unsubscribe, e-mail:
<mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail:
<mailto:tomcat-user-help@jakarta.apache.org>


--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message