tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brett Knights <knig...@tanner.com>
Subject RE: Building mod_jk.so for Linux
Date Tue, 15 Oct 2002 18:22:13 GMT
Actually it turned out not to be the build!

if I edit httpd.conf thus:
...
LoadModule alias_module modules/mod_alias.so
LoadModule rewrite_module modules/mod_rewrite.so
LoadModule perl_module modules/mod_perl.so
LoadModule jk_module modules/mod_jk.so
...

I then mod_jk is not recognized and the errors below are returned when
apache is started

if I change httpd.conf to the following:
...
LoadModule jk_module modules/mod_jk.so
LoadModule alias_module modules/mod_alias.so
LoadModule rewrite_module modules/mod_rewrite.so
LoadModule perl_module modules/mod_perl.so
...

Apache starts properly and mod_jk works.
Can anyone tell me where this is documented?

HTH

> -----Original Message-----
> From: Brett Knights [mailto:knights@tanner.com]
> Sent: Saturday, October 12, 2002 9:53 AM
> To: 'Tomcat Users List'
> Subject: Building mod_jk.so for Linux
> 
> 
> Hi,
> I have a RH Linux 7.2 system with Apache 2.0.42 installed.
> 
> I am trying to compile mod_jk.so for this system.
> 
> I have the jakarta-tomcat-connectors-4.0.6-src files and run 
> the following
> to make the .so
> 
> from jk/native
> ./configure --with-apxs=/usr/local/apache2/bin/apxs
> make
> 
> this process runs without errors but when I copy the mod_jk.so from
> jk/native/apache-2.0 and try to configure and run apache I get:
> 
> Syntax error on line 1025 of /usr/local/apache2/conf/httpd.conf:
> Invalid command 'JkWorkersFile', perhaps mis-spelled or 
> defined by a module
> not included in the server configuration
> 
> I did include the line:
> LoadModule jk_module modules/mod_jk.so
> 
> Any help on this would be much appreciated.
> 
> FWIW I can't run the ant script that is supposed to build the native
> components.
> It fails with the following:
> BUILD FAILED
> file:/usr/local/src/jakarta-tomcat-connectors-4.0.6-src/jk/nat
ive2/build.xml
:341: Link failed libjkjni

--
To unsubscribe, e-mail:
<mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail:
<mailto:tomcat-user-help@jakarta.apache.org>

--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message