tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Turner, John" <JTur...@AAS.com>
Subject RE: Mod_JK, Tomcat 4, and Apache 1.3.27
Date Wed, 23 Oct 2002 18:07:45 GMT

Switch them around:

path="/jsp" docBase="/data/www/docs/jsp" 

See if that makes a difference...you'll need to restart Tomcat.

John


> -----Original Message-----
> From: Curt LeCaptain [mailto:lecaptainc@itol.com]
> Sent: Wednesday, October 23, 2002 2:05 PM
> To: Tomcat Users List
> Subject: Re: Mod_JK, Tomcat 4, and Apache 1.3.27
> 
> 
> This line:
> 
> <Context path="/data/www/docs/jsp" docBase="/jsp" debug="0"
>                  reloadable="true" crossContext="true">
> 
> Is possibly a mistake by me?  I'm just curious... I'm not exactly the
> greatest at this, still quite new to the whole Tomcat server.
> 
> I'm trying to go to linuxdev01.itol.com/jsp (where there are 
> example JSP's)
> and run them from there.
> 
> Curt
> 
> ----- Original Message -----
> From: "Turner, John" <JTurner@AAS.com>
> To: "'Tomcat Users List'" <tomcat-user@jakarta.apache.org>
> Sent: Wednesday, October 23, 2002 1:00 PM
> Subject: RE: Mod_JK, Tomcat 4, and Apache 1.3.27
> 
> 
> >
> > OK, but what URL are you trying to reach?  The only Context 
> you have in
> > server.xml is /manager, so unless you are trying to access
> > http://linuxdev01.itol.com/manager, you are going to get 
> the error message
> > that you're getting.
> >
> > John
> >
> >
> > > -----Original Message-----
> > > From: Curt LeCaptain [mailto:lecaptainc@itol.com]
> > > Sent: Wednesday, October 23, 2002 1:56 PM
> > > To: Tomcat Users List
> > > Subject: Re: Mod_JK, Tomcat 4, and Apache 1.3.27
> > >
> > >
> > >
> > >
> > > >
> > > > This is a server.xml issue.  I guess the best way to
> > > proceed would be for
> > > > you to post the relevant portion of httpd.conf (not the
> > > whole thing, just
> > > > the parts with the JkMount directives), workers.properties,
> > > and server.xml
> > > > as they are now.
> > > >
> > > > My guess is you are accessing something as a hostname like
> > > host.itol.com
> > > but
> > > > the only Host you have in server.xml is "localhost", and
> > > that you are
> > > trying
> > > > to reach something like http://your.host.com/myApp but
> > > there is no Context
> > > > in server.xml for "myApp".
> > >
> > > #Tomcat Workers Properties
> > > JkWorkersFile   /usr/local/tomcat/conf/auto/workers.properties
> > > JkLogFile       /usr/local/apache/logs/mod_jk.log
> > > JkLogLevel      error
> > >
> > > <VirtualHost linuxdev01.itol.com>
> > >     ServerName linuxdev01.itol.com
> > >
> > >     JkMount /data/www/docs/jsp ajp13
> > >     JkMount /data/www/docs/jsp/* ajp13
> > >
> > >     JkMount /manager ajp13
> > >     JkMount /manager/* ajp13
> > > </VirtualHost>
> > >
> > >
> > >
> > > Hopefully this helps as to what I'm doing... I'm thinking I'm
> > > just being an
> > > idiot, but looking for confirmation on this ;-)
> > >
> > > Curt LeCaptain (2 attachements)
> > >
> > >
> >
> > --
> > To unsubscribe, e-mail:
> <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
> > For additional commands, e-mail:
> <mailto:tomcat-user-help@jakarta.apache.org>
> >
> 
> 
> --
> To unsubscribe, e-mail:   
<mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail:
<mailto:tomcat-user-help@jakarta.apache.org>

--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message