tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Turner, John" <JTur...@AAS.com>
Subject RE: Building mod_jk.so for Linux
Date Tue, 15 Oct 2002 18:42:29 GMT

Various...I've been doing a lot of testing.

I use the auto-gen function of Tomcat's ajp13 connector, which puts the
LoadModule statement at the end of httpd.conf.  Two environments I know are
OK (or seem to be, as far as the errors you're seeing are concerned):

Tomcat 4.0.6, homegrown connector (built from source pre 1.2.0), Apache
1.3.26
Tomcat 4.1.10, homegrown connector, Apache 2.0.4x

John

> -----Original Message-----
> From: Brett Knights [mailto:knights@tanner.com]
> Sent: Tuesday, October 15, 2002 2:35 PM
> To: 'Tomcat Users List'
> Subject: RE: Building mod_jk.so for Linux
> 
> 
> 
> 
> This is with TC 4.0.6, TC Connectors 4.0.6, Apache 2.0.42 and 
> Linux Red Hat
> 7.2
> What versions are you using?
> 
> > -----Original Message-----
> > From: Turner, John [mailto:JTurner@AAS.com]
> > Sent: Tuesday, October 15, 2002 11:28 AM
> > To: 'Tomcat Users List'
> > Subject: RE: Building mod_jk.so for Linux
> > 
> > 
> > 
> > That's pretty strange.  Mod_jk is the last module loaded for 
> > me, at the very
> > end of httpd.conf, and it works perfectly.
> > 
> > John
> > 
> > 
> > > -----Original Message-----
> > > From: Brett Knights [mailto:knights@tanner.com]
> > > Sent: Tuesday, October 15, 2002 2:22 PM
> > > To: 'Tomcat Users List'
> > > Subject: RE: Building mod_jk.so for Linux
> > > 
> > > 
> > > Actually it turned out not to be the build!
> > > 
> > > if I edit httpd.conf thus:
> > > ...
> > > LoadModule alias_module modules/mod_alias.so
> > > LoadModule rewrite_module modules/mod_rewrite.so
> > > LoadModule perl_module modules/mod_perl.so
> > > LoadModule jk_module modules/mod_jk.so
> > > ...
> > > 
> > > I then mod_jk is not recognized and the errors below are 
> > returned when
> > > apache is started
> > > 
> > > if I change httpd.conf to the following:
> > > ...
> > > LoadModule jk_module modules/mod_jk.so
> > > LoadModule alias_module modules/mod_alias.so
> > > LoadModule rewrite_module modules/mod_rewrite.so
> > > LoadModule perl_module modules/mod_perl.so
> > > ...
> > > 
> > > Apache starts properly and mod_jk works.
> > > Can anyone tell me where this is documented?
> > > 
> > > HTH
> > > 
> > 
> > --
> > To unsubscribe, e-mail:   
> > <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
> > For additional commands, e-mail: 
> > <mailto:tomcat-user-help@jakarta.apache.org>
> > 
> 
> --
> To unsubscribe, e-mail:   
<mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail:
<mailto:tomcat-user-help@jakarta.apache.org>

--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message