tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Turner, John" <JTur...@AAS.com>
Subject RE: Configuring Tomcat4.1 to use Apache2.0.43 win32, Doc's not cl ear
Date Tue, 08 Oct 2002 12:46:25 GMT

In addition to Jacob's concise post, I would add that if you can, re-install
everything to places with NO spaces in the pathnames.  Yes, the Apache
installer puts things in a path with spaces, but the people who wrote the
Apache installer were never concerned with what effect that would have on
integrating other things with Apache.  Based on my experience, and other
posts on the lists, integrating Apache with Tomcat can be problematic if
your pathnames have spaces.

John


> -----Original Message-----
> From: Admin Dobsons.org [mailto:jmail@dobsons.org]
> Sent: Monday, October 07, 2002 11:20 PM
> To: tomcat-user@jakarta.apache.org
> Subject: Configuring Tomcat4.1 to use Apache2.0.43 win32, Doc's not
> clear
> 
> 
> I'm trying to configure Tomcat 4.1 to run under Apache 2.0.43 
> on Windows
> 2000 Advanced server
> 
> I have succesfuly installed
> Apache 2.0.43
> j2sdk-1_4_1-windows
> Tomcat 4.1
> 
> I'm having trouble connecting Tomcat and Apache.
> 
> I've read all the documents and everytime I think I know were 
> to go to edit
> a file or look for a auto created file its not there.
> 
> I would like to use the Apache auto-configure or any other 
> method that is
> easy so I can begin the learning process.
> 
> What I've try so far:
> *Installed applications
> -Apache 2.0.43
> -j2sdk-1_4_1-windows
> -Tomcat 4.1
> 
> *Edited httpd.conf
> Just added >   Include "C:\Program Files\Apache Group\Tomcat
> 4.1/conf/jk/mod_jk.conf-auto"
> 
> *Copied mod_jk-2.0.42.dll
> Into > C:\Program Files\Apache Group\Apache2\modules
> 
> *Edit server.xml looked for "<AutoWebApp" in C:\Program Files\Apache
> Group\Tomcat 4.1\conf\server.xml
> I could not find any line with AutoWebApp in it.
> So I just added <ApacheConfig />  just above the final </server>
> 
> Here is an exerpt from the manual
> "To configure Tomcat to generate the Apache auto-configuration add the
> following block to your TOMCAT_HOME/conf/server.xml file 
> after <AutoWebApp
> ... />.
> <ApacheConfig />"
> 
> This is were I get lost. Also I'm not sure I'm copying the 
> dll into the
> right directory. All the other files in the module directory 
> are of the .so
> extention so the mod_jk-2.0.42.dll is the only dll.The manual 
> is also not
> specif were to put the dll. or at least the path is not 
> refference the same
> as my instalation.
> 
> Thanks in advance for any and all support
> 
> You can reach me at jmail@dobsons.org or the board.
> 
> 
> 
> 
> 
> 
> --
> To unsubscribe, e-mail:   
<mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail:
<mailto:tomcat-user-help@jakarta.apache.org>

--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message