tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tom Palmer <t...@uk.uu.net>
Subject RE: [Jk2] Can't run mod_jk2 against Apache 2.0.41+
Date Mon, 14 Oct 2002 13:28:50 GMT
Hi,

  The patch for apr-0 is necessary because, for some reason, libapr.so is
actually libapr-0.so in Apache 2.0.43 hence linking against -lapr will fail.

  Regards,

  Tom

> -----Original Message-----
> From: Brzezinski, Paul J [mailto:Paul.Brzezinski@EDS.COM]
> Sent: 14 October 2002 14:41
> To: Tomcat Users List
> Subject: Re: [Jk2] Can't run mod_jk2 against Apache 2.0.41+
> 
> 
> Didn't try this against Apache 2.0.43, but had to make 
> similar mods to 
> Makefile.in in jk/native2/server/apache2.  
> 
> I'm posting a response because I would like to know what is apr-0?
> 
> I've built 2.0.40, jk2 on Solaris using 64-bit gcc 3.1 and cannot get 
> the ChannelUnix tomcat connector to work.
> 
> Tom Palmer wrote:
> 
> >Hi,
> >
> >  I'm having a problem running mod_jk2 with anything greater 
> than Apache
> >2.0.40. I can build mod_jk2 against the later versions of 
> Apache2 (e.g.
> >2.0.43) but if I then try and run apache I get the following 
> error reported:
> >
> >"httpd: module "../../server/apache2/mod_jk2.c" is not 
> compatible with this
> >version of Apache (found 20020628, need 20020903).
> >Please contact the vendor for the correct version."
> >
> >  (this is reported from 2.0.43). I've tried using the 2.0.1 
> release and a
> >recent CVS checkout and have had the same error regardless.
> >
> >  FYI I'm building on solaris 8 with gcc 3.2. 
> jk/native2/apache2/Makefile.in
> >has been patched to pass in -DBSD_COMP in order for it to 
> build correctly
> >under solaris. It has also been patched to link against 
> apr-0 instead of
> >apr. configure is run with the following args: 
> --with-apxs2=<path to apache2
> >apxs> --with-java-home=/usr/j2se.
> >
> >  I'm guessing that this is somehow related to the solaris 
> build as there
> >are binaries for mod_jk2 against 2.0.43 under linux. Has 
> anyone else had
> >this problem or have any idea how to fix it?
> >
> >  Thanks,
> >
> >  Tom
> >
> >--
> >To unsubscribe, e-mail:   
> <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
> >For additional commands, e-mail: 
> <mailto:tomcat-user-help@jakarta.apache.org>
> >  
> >
> 
> 
> 
> 
> 
> --
> To unsubscribe, e-mail:   
> <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
> For additional commands, e-mail: 
> <mailto:tomcat-user-help@jakarta.apache.org>
> 

--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message