tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tom Palmer <t...@uk.uu.net>
Subject [Jk2] Can't run mod_jk2 against Apache 2.0.41+
Date Mon, 14 Oct 2002 12:35:33 GMT
Hi,

  I'm having a problem running mod_jk2 with anything greater than Apache
2.0.40. I can build mod_jk2 against the later versions of Apache2 (e.g.
2.0.43) but if I then try and run apache I get the following error reported:

"httpd: module "../../server/apache2/mod_jk2.c" is not compatible with this
version of Apache (found 20020628, need 20020903).
Please contact the vendor for the correct version."

  (this is reported from 2.0.43). I've tried using the 2.0.1 release and a
recent CVS checkout and have had the same error regardless.

  FYI I'm building on solaris 8 with gcc 3.2. jk/native2/apache2/Makefile.in
has been patched to pass in -DBSD_COMP in order for it to build correctly
under solaris. It has also been patched to link against apr-0 instead of
apr. configure is run with the following args: --with-apxs2=<path to apache2
apxs> --with-java-home=/usr/j2se.

  I'm guessing that this is somehow related to the solaris build as there
are binaries for mod_jk2 against 2.0.43 under linux. Has anyone else had
this problem or have any idea how to fix it?

  Thanks,

  Tom

--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message