tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "M. Hockings" <veeshoo...@hockings.net>
Subject Re: need help connecting Tomcat 4.1.12, Apache 2.0.43 using jk2 ( mod_jk2-2.0.43.dll)
Date Thu, 31 Oct 2002 16:41:50 GMT
Thanks Robert,

That almost did the trick.  With the path set up correctly then Tomcat 
seemed to init OK but still had errors in connecting.  To finally get it 
to work I found that I needed to explicitly state 
channelSocket.port=8009 in the jk2.properties.  For the classpath I 
defined it using the $(TOMCAT_HOME) variable to keep things as adaptive 
as possible and it worked fine.

I must say that your document was invaluable in getting this to work  -- 
it should be included in the "official" Tomcat docs (IMHO).

Kind regards,

Mike

Robert L Sowders wrote:

>Don't know why but the classpath lines in the new workers2.properties file 
>has changed.  I tried the old method and it works again.  Don't know why 
>it pitched a fit.  Perhaps it needs to be quoted or something.
>
>To fix it just replace both class path lines in the [VM] section of 
>workers2.properties with the following.
>
>OPT=-Djava.class.path=c:/Tomcat/bin/tomcat-jni.jar;c:/Tomcat/server/lib/commons-logging.jar
>
>Sorry for the confusion.
>
>rls
> 
>
>
>
>
>"M. Hockings" <veeshooter@hockings.net>
>10/30/2002 07:59 PM
>Please respond to "Tomcat Users List"
>
> 
>        To:     Tomcat Users List <tomcat-user@jakarta.apache.org>
>        cc: 
>        Subject:        Re: need help connecting Tomcat 4.1.12, Apache 2.0.43 using jk2
( 
>mod_jk2-2.0.43.dll)
>
>
>Hi Newbie,
>
>In the workers2.properties it is ${TOMCAT_HOME}/bin/tomcat-jni.jar. 
> I've tried hard-coding it with forward slashes but the result was the 
>same.  There is probably something very simple that I'm overlooking.
>
>Thanks,
>
>Mike
>
>Tomcat Newbie wrote:
>
>  
>
>>How about the slashes in your path?
>>
>>C:\ApacheGroup\Tomcat4.1/bin/tomcat-jni.jar
>>                                         ^^^
>>
>>----- Original Message -----
>>From: "M. Hockings" <veeshooter@hockings.net>
>>To: "Tomcat Users List" <tomcat-user@jakarta.apache.org>
>>Sent: Wednesday, October 30, 2002 10:00 PM
>>Subject: Re: need help connecting Tomcat 4.1.12, Apache 2.0.43 using jk2 
>>    
>>
>(
>  
>
>>mod_jk2-2.0.43.dll)
>>
>>
>>
>>
>>    
>>
>>>Hello,
>>>
>>>I too am trying to get this configuration working to give me a test
>>>environment that duplicates a remote server.  I have followed the
>>>instructions pointed to by John Turner very closely and only modified
>>>the line in workers2.properties that points to the jvm.dll.  When I
>>>start Apache I see the following in logs\error.log.   If you have any
>>>hints or suggestions about what I have set up incorrectly please let me
>>>know.  Both Apache and Tomcat seem to work fine individually.
>>>
>>>Thanks,
>>>
>>>Mike
>>>
>>>
>>>      
>>>
>>--
>>To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
>>For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>
>>
>>
>>
>>    
>>
>
>  
>

-- 

Note new email address -> veeshooter@hockings.net <-

Mike's Page               :  http://www.hockings.net/~mike
Rifle Shooting in Ontario :  http://www.hockings.net/rso/
Scarborough Rifle Club    :  http://www.hockings.net/rso/src/
Canadian Shooting Sports  :  http://www.CdnShootingSports.org
Ontario Rifle Association :  http://www.OntarioRifleAssociation.org



Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message