tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Aryeh Katz" <ar...@vasco.com>
Subject Re: servlet mapping help
Date Tue, 15 Oct 2002 17:17:04 GMT
> Hello Aryeh,
> 
> The proper syntax is:
> 
> JkMount /examples/servlets/* ajp13
> 
> You define the protocol, not a worker after the mount pattern.
This did not help matters. Even after changing httpd.conf and 
workers.properties, I get the same behavior.
Just one question. Can you point me to documentation that says it's
the protocol, not the worker? The web page
http://jakarta.apache.org/tomcat/tomcat-4.1-
doc/jk2/jk/aphowto.html#mod_jk%20Directives seems to imply it's the
worker, along with the mod_jk comments (lines 660 and 1412 in v 
4.0.6), that state it's a worker. Thanks for your help. 
Aryeh 
> > Jake
> >Tuesday, October 15, 2002, 11:03:01 AM, you wrote: > > AK> I'm trying
to integrate mod_jk and tomcat. > AK> My httpd.conf file has the
following mapping > > AK> JkMount /examples/servlets/* worker1 > > 
AK>
and I see the following in my jk log file (at debug) > > AK> [Tue Oct
15 11:52:17 2002]  [jk_uri_worker_map.c (321)]: Into   

> AK> jk_uri_worker_map_t::uri_worker_map_open, match rule AK>
> /examples/servlets/=worker1 was added [Tue Oct 15 11:52:17 2002] 
AK>
> [jk_uri_worker_map.c (408)]: Into AK>
> jk_uri_worker_map_t::uri_worker_map_open, there are 1 rules [Tue 
Oct
> AK> 15 11:52:17 2002]  [jk_uri_worker_map.c (422)]: AK>
> jk_uri_worker_map_t::uri_worker_map_open, done [Tue Oct 15 11:52:20
> AK> 2002]  [jk_uri_worker_map.c (460)]: Into AK>
> jk_uri_worker_map_t::map_uri_to_worker [Tue Oct 15 11:52:20 2002] 
AK>
> [jk_uri_worker_map.c (477)]: Attempting to map URI AK>
> '/examples/servlets/HelloWorldExample' [Tue Oct 15 11:52:20 2002] 
AK>
> [jk_uri_worker_map.c (502)]: 
jk_uri_worker_map_t::map_uri_to_worker,
> AK> Found a context match worker1 -> /examples/servlets/ [Tue Oct 
15
> AK> 11:52:20 2002]  [jk_worker.c (132)]: Into 
wc_get_worker_for_name
> AK> worker1 [Tue Oct 15 11:52:20 2002]  [jk_worker.c (136)]: AK>
> wc_get_worker_for_name, done did not found a worker
> 
> AK> Why is my worker getting lost? Do I have some kind of 
> AK> misconfiguration?

---
Aryeh Katz
VASCO 			
www.vasco.com		

--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message