tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mark R. Diggory" <mdigg...@latte.harvard.edu>
Subject Re: Jasper complains when parsing valid TLD (was: Can't deploy Custom Tag Library ... )
Date Wed, 09 Oct 2002 19:51:36 GMT
If anyone was concered about this issue, it looks like the Forte fixed 
this issue and my taglibraries are old and need to be updated to include 
the chages.

Mark R. Diggory wrote:

> Hmmm, this definitly looks like a booger in Forte's TLD generation 
> code... I'll have to *go bug them* for awhile now!
>
> Thank you Jan,
> -M.
>
> Jan Luehe wrote:
>
>> Mark,
>>
>>  
>>
>>> So, on 4.1.* with logging cranked way up, I've been seeing errors 
>>> that Jasper encountered a TEI class when the tld already has a 
>>> variable? Very wierd error. Here's an example of a tag in my taglib, 
>>> if anyone sees anything wrong with this please let me know, it is 
>>> still valid against the dtd. (again this was a tld generated by 
>>> Forte4J).
>>>   
>>
>>
>> I believe the warning you are getting is based on JSP 1.2, JSP.C
>> ("DTD for TagLibrary Descriptor, JSP 1.2"), p.231:
>>
>>  It is a (translation time) error for an action that
>>  has one or more variable subelements to have a TagExtraInfo
>>  class that returns a non-null object.
>>  
>>  
>> Jan
>>
>>
>> --
>> To unsubscribe, e-mail:   
>> <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
>> For additional commands, e-mail: 
>> <mailto:tomcat-user-help@jakarta.apache.org>
>>
>>  
>>
>
>
>
>
>
> --
> To unsubscribe, e-mail:   
> <mailto:taglibs-dev-unsubscribe@jakarta.apache.org>
> For additional commands, e-mail: 
> <mailto:taglibs-dev-help@jakarta.apache.org>
>





--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message