tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From John Mattos <matt...@yahoo.com>
Subject Re: Testing Datasources
Date Thu, 31 Oct 2002 21:23:15 GMT

Ah! Thank you! Good catch. Alright 2 more dumb questions (I'm not above that) in web xml,
the <resource-ref> is...
  <resource-ref>
      <description>DB Connection</description>
      <res-ref-name>jdbc/indemand</res-ref-name>
      <res-type>javax.sql.DataSource</res-type>
      <res-auth>Container</res-auth>
  </resource-ref>

Correct?

Also, the db url I'm using is...

jdbc:microsoft:sqlserver://vc34:1433;databaseName=TibcoClearHouse

and I'm wondering if that's in the right format...

Thanks

John


 shawn <shawn@wnsi.net> wrote:driverClassName is :
com.microsoft.jdbc.sqlserver.SQLServerDriver



driverClassName
com.microsoft.jdbc.sqlserver.SQLServerDriver




Not :
C:\Tomcat4.1\common\lib\msbase.jar;C:\Tomcat4.1\common\lib\mssqlserver.jar;C:\Tomcat4.1\common\lib\msutil.jar
these need to be somewhere in your classpath....


Also do not forget the resource-ref in web.xml

On Thursday 31 October 2002 01:49 pm, John Mattos wrote:
> Ah... interesting. No, I can't see them loading, but they're set up at the
> app and global level. Why wouldn't they be loading?
>
> Here's a snippet from server.xml....
> 
> 

> validationQuery
> select top 100 * from Subscriber
> 

> 

> url
> 
> jdbc:microsoft:sqlserver://vc34:1433;databaseName=TibcoClearHouse>alue> 

> 

> password
> tibco_user
> 

> 

> maxActive
> 12
> 

> 

> maxWait
> 5000
> 

> 

> driverClassName
> 
> C:\Tomcat4.1\common\lib\msbase.jar;C:\Tomcat4.1\common\lib\mssqlserv
>er.jar;C:\Tomcat4.1\common\lib\msutil.jar; 

> 

> username
> tibco_user
> 

> 
> Thoughts?
> pqin@shareowner.com wrote:Where do you setup your datasource? If Global or
> default context, you should be able to see JNDI reference loading when you
> start your tomcat.
>
> Regards,
>
>
> Phillip Qin
>
> Software Developer
> Canadian Shareowner
> 121 Richmond Street W, 7th Floor
> Toronto, ON M5H 2K1
> (416) 595-9600 ext 291
>
>
> -----Original Message-----
> From: John Mattos [mailto:mattosj@yahoo.com]
> Sent: October 31, 2002 3:33 PM
> To: Tomcat Users List
> Subject: Testing Datasources
>
>
> Is there as easy way to test datasources I set up in server.xml (or in the
> Administrator app)?
>
>
> John L. Mattos
> 302 East 88th Street Apt #5B
> New York, New York 10128-4939
> (M) (917) 202-8450
> (www) http://www.mattos.ws
>
>
> ---------------------------------
> Do you Yahoo!?
> HotJobs - Search new jobs daily now
>
>
>
> ---------------------------------
> Yahoo! - We Remember
> 9-11: A tribute to the more than 3,000 lives lost


--
To unsubscribe, e-mail: 
For additional commands, e-mail: 



---------------------------------
Do you Yahoo!?
HotJobs - Search new jobs daily now
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message