tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "John Byrd" <john.b...@darkspell.com>
Subject RE: Tomcat 4.1X seems broken on Linux
Date Thu, 17 Oct 2002 00:17:58 GMT
WOW!!!
Worked like a champ! 
Thanks for sharing.

> 
> I had a similar problem. I was not using JMX MBeans. The
> default server.xml opens up listeners for it. 
> 
> Comment them out and TC will most likely startup .
> 
> These are the lines to look for to comment out. They are
> near the top.
> ---
>   <!-- Uncomment these entries to enable JMX MBeans support -->
>   <Listener
className="org.apache.catalina.mbeans.ServerLifecycleListener" 
> debug="0"/>
>   <Listener
> className="org.apache.catalina.mbeans.GlobalResourcesLifecycleListener"
> debug="0"/>
> ----
> 
> 
> I hope this helps.
> 
> -k
> 
> 
> 
> -----Original Message-----
> From: John Byrd [mailto:john.byrd@darkspell.com]
> Sent: Tuesday, October 15, 2002 11:12 PM
> To: Tomcat Users List
> Cc: Jean-Francois Arcand
> Subject: Re: Tomcat 4.1X seems broken on Linux
> 
> 
> I'm using the server.xml that comes w/ the distro, untouched. It's
> attached. 
> 
> > 
> > 
> > John Byrd wrote:
> > 
> > >Good evening all. Excuse me if you've seen this issue before, but my
> > >cursory search of the archives did not turn it up.
> > >
> > >I have been using Tomcat for several years. Currently on my Linux box I
> > >have versions 3.3.1, 4.0.4, 4.0.5, 4.0.6, 4.1.3, 4.1.6 and 4.1.12. 
> > >
> > >They all work superbly except for the 4.1.x versions. I cannot get any
> > >of those to start. They write to catalina.out a complaint that they're
> > >experiencing a ClassNotFoundException w/r/t
> org.catalina.core.StandardServer
> > >
> > >I'm certain that this is one of those annoying JVM messages that leads
> > >you down the wrong path. The catalina.jar, which contains
> > >StandardServer, is most definitely on the classpath. 
> > >
> > >My guess is that the error occurs in parsing some configuration file,
> > >because the exception line is preceded by this line: 
> > >org.apache.commons.digester.Digester startElement
> > >SEVERE: Begin event threw exception
> > >
> > Actually, this is the exception. Can you post your server.xml file?
> > 
> > -- Jeanfrancois
> > 
> > >
> > >If anyone has a clue as to the fix to this situation please let me
know.
> > >I'd like to move up from the 4.0.x level.
> > >  
> > >
> > 
> > 
> > --
> > To unsubscribe, e-mail:  
> <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
> > For additional commands, e-mail:
> <mailto:tomcat-user-help@jakarta.apache.org>
> > 
> > 
> 
> -- 
> John Byrd
> john.byrd@darkspell.com
> 
> 

-- 
John Byrd
john.byrd@darkspell.com

--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message