tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Eggers <its_toas...@yahoo.com>
Subject Re: trouble with upgrade to a newer version of Tomcat
Date Tue, 15 Oct 2002 20:03:53 GMT
Lisa,

Here's how I've upgraded Tomcat in the past.  I
haven't done the 3.x to the 4.0.x in a very long time,
so I may not remember everything.

1. Copy all of your apps from %TOMCAT_HOME%\webapps to
another location.

2. Copy any customised configuration files (most
likely workers.properties, uriworkermap.properties,
tomcat-users.xml) and the isapi dlls to another
location.

3. Uninstall (Add/Remove Applications) Tomcat 3.x

4. If you used one of the freely available Java-->NT
services packages (I've used JavaService from
http://www.alexandriasc.com/software/JavaService/index.html),
then follow the instructions to remove that.

5. If there is any remaining cruft in %TOMCAT_HOME%,
delete it.

6. Install Tomcat 4.0.6 with the NT service. USE THE
SAME %TOMCAT_HOME%.  This way you won't have to change
environment variables or re-edit the registry.  You
shouldn't have to change your virtual directory
definitions either.

7. Copy your application back into
%TOMCAT_HOME%\webapps.

8. Back up the supplied workers.properties,
uriworkermap.properties, tomcat-users.xml files and
replace them with yours.

9. Add the dlls back into place.

10. Restart everything, and it should all be there.

I did this when I moved from 4.0.5 to 4.1.12 and
everything came up roses.

I hope this helps.

/mde/

just my two cents . . .



--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message