tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kent Perrier <kperr...@ev1.net>
Subject Configuration question
Date Tue, 15 Oct 2002 18:37:47 GMT
All,

I have been having problems getting Apache 2.0.40 and Tomcat 4.0.6 configured
properly.  Due to time issues, I have decided to drop the apache part of my
configuration and run Tomcat as root so it can bind to port 80 and 443.  I am
running into a strange issue that I hope you all can help me out with.

Server configuration: Dell Poweredge running RedHat Linux 7.2

In attempting to test my configuration, I am using lynx to test the server to
make sure everything is working.  When I execute the command lynx http://localhost/
or lynx http://<eth0 IP address>/ or http://127.0.0.1/ I get this error in lynx:

Alert!: HTTP/1.1 400 No Host matches server name 127.0.0.1
Alert!: HTTP/1.1 400 No Host matches server name <eth0 IP address>
Alert!: HTTP/1.1 400 No Host matches server name localhost

I'm sure you get the picture.

In my server.xml, I have my Host name parameter for my default virtual host
set to the EVENTUAL dns host name for this server.  Currently, the machine's
IP address is not DNS resolvable.  Is Tomcat giving me the error 400 because
the hostname (localhost, IP address, 127.0.0.1) is not configured as a virtual
host in Tomcat?

Thanks,

Kent

--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message