tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From John Lee <capu91...@uunet.com.au>
Subject Tomcat 4.1.12 IIS 5 Redirector Problem
Date Thu, 01 Jan 1970 00:00:00 GMT
Hi all,

I cannot get this ISAPI redirector to work for JSP/Servlet programs running in the following
platform:
01. TOMCAT 4.1.12 
02. JDK 1.4.1
03. ISAPI_REDIRECTOR.DLL 
04. IIS 5
05. W2KP SP3


11. I successfully did a http://localhost:8080/jsp/examples/index.html
12. However, I got a HTTP 500 (Internal Server Error) error when I did http://localhost/jsp/examples/index.html
13. In ISAPI log, it shows the following:
[jk_isapi_plugin.c (696)]: HttpFilterProc started
[jk_isapi_plugin.c (759)]: In HttpFilterProc Virtual Host redirection of /localhost/examples/jsp/index.html
[jk_uri_worker_map.c (460)]: Into jk_uri_worker_map_t::map_uri_to_worker
[jk_uri_worker_map.c (477)]: Attempting to map URI '/localhost/examples/jsp/index.html'
[jk_uri_worker_map.c (599)]: jk_uri_worker_map_t::map_uri_to_worker, done without a match
[jk_isapi_plugin.c (765)]: In HttpFilterProc test Default redirection of /examples/jsp/index.html
[jk_uri_worker_map.c (460)]: Into jk_uri_worker_map_t::map_uri_to_worker
[jk_uri_worker_map.c (477)]: Attempting to map URI '/examples/jsp/index.html'
[jk_uri_worker_map.c (502)]: jk_uri_worker_map_t::map_uri_to_worker, Found a context match
ajp13 -> /examples/
[jk_isapi_plugin.c (775)]: HttpFilterProc [/examples/jsp/index.html] is a servlet url - should
redirect to ajp13
[jk_isapi_plugin.c (838)]: HttpFilterProc check if [/examples/jsp/index.html] is points to
the web-inf directory


21. I have already read http://members.ozemail.com.au/~lamplante/howto/tomcat/iisnt.
22. *** I checked the http://jakarta.apache.org/tomcat/tomcat-4.1-doc/jk2/jk/iishowto.html
and on the last page, it talks about "Check the workers.properties file and make sure that
the port setting for worker.ajp12.port is the same as the port specified in the server.xml
for the Apache AJP12 support".
23. *** In server.xml, there is no ajp12 defined at all but it was mentioned in workers.properties
and I think the cause of the problem is somehow ajp12 is required for the demo programs but
somehow it was missing but I do not know how to put it in.

This is the same problem posted on Sep 26 but no real solution was posted.

Any suggestions?

Cheers.


John



--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message