tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "rdevine" <rdevin...@yahoo.com>
Subject Unable to get JSP to run - Tomcat 4.0.6
Date Tue, 15 Oct 2002 15:32:06 GMT
Hello all.  I'm not sure this is the right place to ask but being new to
JSP I'll give it a shot and thanks in advance for any help you can
supply.
 
I am running winXP - Home.  jdk1.3.1_02
Installed tomcat4.0.6 without any problems.  Changed config as follows :
    JAVA_HOME = c:\jdk1.3.1_02
    CATALINA_HOME = c:\jakarta-tomcat-4.0.6
    CLASSPATH = c:\jakarta-tomcat-4.0.6\common\lib\servlet.jar;.
    PATH = added to existing path c:jdk1.3.1_02
 
 
http://localhost:8080/index.html gives me the Tomcat page.  I am able to
execute the JSP examples without problem.
 
When I create my own .jsp file (simple one) in
c:\jakarta-tomcat-4.0.6\webapps\begjsp-ch01\index.jsp, set the address
to http://localhost:8080/begjsp-ch01/index.jsp  I receive the error
message : 
 
404 - webapps/index.jsp                                             
  type Status report

 message /webapps/indx.jsp

 description The requested resource (/webapps/indx.jsp) is not
available.

JSP/HTML code - 

<html>

<head>

<title>My First JSP</title>

</head>

<body>

Hello World!<br>

the current date and time is <%= new java.util.Date() %>

</body>

</html>

I have checked and double, triple checked all spellings, syntax in the
.jsp file and the config settings and cannot find anything different
from what is in the text I am using (on my own, Beginning JSP Web
Development - WROX.)  Java has been working fine since the beginning of
the year.

Any suggestions will be GREATLY appreciated as I am at a standstill.

Bob Devine


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message