tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From charbel.ach...@teradyne.com
Subject Tomcat 4.0.4 and Apache 1.3.26 and mod_jk issues
Date Wed, 11 Sep 2002 21:33:59 GMT

---------------------- Forwarded by Charbel Achkar/Bos/Teradyne on
09/11/2002 05:34 PM ---------------------------


Charbel Achkar
09/11/2002 05:20 PM

To:   tomcat-user-info@jakarta.apache.org
cc:

Subject:  Tomcat 4.0.4 and Apache 1.3.26 and mod_jk


Hello,

I have installed and configured Apache 1.3.26 with modssl and openssl  +
tomcat 4.0.4 with the corresponding Apache mod_jk. I started tomcat then
apache and when I attempted to access the index.jsp under ROOT, the browser
hangs and goes no where. the following error can be observed when info mode
is set in httpd.conf

INFO

[Mon Sep 09 18:18:39 2002]  [jk_ajp_common.c (652)]: ajp_connection_tcp_get_message: Error
- jk_tcp_socket_recvfull failed
[Mon Sep 09 18:18:39 2002]  [jk_ajp_common.c (1013)]: Error reading reply
[Mon Sep 09 18:18:39 2002]  [jk_ajp_common.c (1150)]: In jk_endpoint_t::service, ajp_get_reply
failed in send loop 0
[Mon Sep 09 18:18:39 2002]  [jk_connect.c (151)]: jk_open_socket, connect() failed errno =
146
[Mon Sep 09 18:18:39 2002]  [jk_ajp_common.c (599)]: In jk_endpoint_t::ajp_connect_to_endpoint,
failed errno = 146
[Mon Sep 09 18:18:39 2002]  [jk_ajp_common.c (844)]: Error connecting to the Tomcat process.
[Mon Sep 09 18:18:39 2002]  [jk_ajp_common.c (1153)]: In jk_endpoint_t::service, ajp_send_request
failed in send loop 1
[Mon Sep 09 18:18:39 2002]  [jk_connect.c (151)]: jk_open_socket, connect() failed errno =
146
[Mon Sep 09 18:18:39 2002]  [jk_ajp_common.c (599)]: In jk_endpoint_t::ajp_connect_to_endpoint,
failed errno = 146
[Mon Sep 09 18:18:39 2002]  [jk_ajp_common.c (844)]: Error connecting to the Tomcat process.
[Mon Sep 09 18:18:39 2002]  [jk_ajp_common.c (1153)]: In jk_endpoint_t::service, ajp_send_request
failed in send loop 2


And the followin is observed under DEBUG mode


[Wed Sep 11 16:53:04 2002]  [jk_uri_worker_map.c (460)]: Into jk_uri_worker_map_t::map_uri_to_worker
[Wed Sep 11 16:53:04 2002]  [jk_uri_worker_map.c (477)]: Attempting to map URI '/test.jsp'
[Wed Sep 11 16:53:04 2002]  [jk_uri_worker_map.c (558)]: jk_uri_worker_map_t::map_uri_to_worker,
Found a suffix match jakarta-tomcat-4.0.4 -> *.jsp
[Wed Sep 11 16:53:04 2002]  [jk_worker.c (132)]: Into wc_get_worker_for_name jakarta-tomcat-4.0.4
[Wed Sep 11 16:53:04 2002]  [jk_worker.c (136)]: wc_get_worker_for_name, done  found a worker
[Wed Sep 11 16:53:04 2002]  [jk_ajp_common.c (1355)]: Into jk_worker_t::get_endpoint
[Wed Sep 11 16:53:04 2002]  [jk_ajp_common.c (1079)]: Into jk_endpoint_t::service
[Wed Sep 11 16:53:04 2002]  [jk_ajp_common.c (280)]: Into ajp_marshal_into_msgb
[Wed Sep 11 16:53:04 2002]  [jk_ajp_common.c (413)]: ajp_marshal_into_msgb - Done
[Wed Sep 11 16:53:04 2002]  [jk_connect.c (116)]: Into jk_open_socket
[Wed Sep 11 16:53:04 2002]  [jk_connect.c (123)]: jk_open_socket, try to connect socket =
9
[Wed Sep 11 16:53:04 2002]  [jk_connect.c (132)]: jk_open_socket, after connect ret = 0
[Wed Sep 11 16:53:04 2002]  [jk_connect.c (140)]: jk_open_socket, set TCP_NODELAY to on
[Wed Sep 11 16:53:04 2002]  [jk_connect.c (148)]: jk_open_socket, return, sd = 9
[Wed Sep 11 16:53:04 2002]  [jk_ajp_common.c (589)]: In jk_endpoint_t::ajp_connect_to_endpoint,
connected sd = 9
[Wed Sep 11 16:53:04 2002]  [jk_ajp_common.c (613)]: sending to ajp13 #379
[Wed Sep 11 16:53:04 2002]  [jk_ajp_common.c (854)]: ajp_send_request 2: request body to send
0 - request body to resend 0

Why is the browser locking and what is happening?

Thanks!





--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message