tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
Subject Apache 2.0.40, mod_jk core dump on AIX
Date Mon, 09 Sep 2002 14:57:12 GMT
Hi everyone,

I want to use mod_jk for integrating Tomcat 4.0.4 and Apache 2.0.40 on AIX
So I downloaded the j-t-c from CVS to get the latest source and followed
the instructions:

./configure --with-apxs=/www/apache2/bin/apxs
make install

There were 2 minimal things:
1) the path to libtool in the common/Makefile was wrong -> should be
2) in the apache-2.0 directory I used the Makefile.apxs instead of

It compiled very well and also installed into /www/apache2/modules,
but by typing: apachectl configtest  it core-dumped.

I tried to figure out with gdb what was going on, but I have to say - I
don't even
understand the output.

Perhaps does anyone of you?

(gdb) where
#0  0xd155ce40 in ap_hook_handler () at config.c:193
#1  0xd155f52c in jk_register_hooks (p=0x300afb14) at mod_jk.c:1715
#2  0x1000ae68 in ap_register_hooks (m=0x300af1a8, p=0x30028d40) at
#3  0x1000b04c in ap_add_module (m=0x300af1a8, p=0x30028d40) at
#4  0x1000b18c in ap_add_loaded_module (mod=0x300af1a8, p=0x0) at
#5  0x1005813c in load_module (cmd=0x2ff22818, dummy=0x300af1a8,
    modname=0x3009c408 <Address 0x3009c408 out of bounds>,
    filename=0x3003c020 <Address 0x3003c020 out of bounds>) at mod_so.c:323
#6  0x1000b85c in invoke_cmd (cmd=0x30002ee0, parms=0x2ff22818,
    mconfig=0x2ff20760, args=0x2ff207ee "") at config.c:736
#7  0x1000cf9c in execute_now (
    cmd_line=0x3009c3b8 <Address 0x3009c3b8 out of bounds>,
    args=0x2ff207d3 "jk_module modules/", parms=0x2ff22818, p=0xa,
    ptemp=0x53, sub_tree=0x2ff20760, parent=0x20002ef0) at config.c:1342
#8  0x1000c324 in ap_build_config_sub (p=0x30028d40, temp_pool=0x300731e0,
    parms=0x2ff22818, current=0x2ff227c8, curr_parent=0x2ff227cc,
    conftree=0x3000157c) at config.c:939
#9  0x1000c968 in ap_build_config (parms=0x2ff22818, p=0x30028d40,
    temp_pool=0x300731e0, conftree=0x3000157c) at config.c:1146
#10 0x1000d56c in ap_process_resource_config (s=0x3003bd80,
    fname=0x30076600 <Address 0x30076600 out of bounds>,
    p=0x30028d40, ptemp=0x300731e0) at config.c:1527
#11 0x1000dfc8 in ap_read_config (process=0x300afb14, ptemp=0x300731e0,
    filename=0x10066c9c "conf/httpd.conf", conftree=0x3000157c) at
#12 0x10001048 in main (argc=2, argv=0x2ff22acc) at main.c:557
#13 0x100001dc in __start ()

I search the net and almost every newsgroup where mod_jk or tomcat were
discussed, and
it seams that building mod_jk as DSO on AIX is quite a challenge :)
I did this for Apache 1.3.22 on AIX and found the hint to add "-bexpall" to
in the apxs script. That worked - but there's nothing similar for Apache
2.0.40. Sad but true.

Perhaps it is important that I have patched the source of Apache with the
openssl-patch and
the AIX-specific apr-util patch available from

thanks in advance,
and greetings from austria,

Johannes Grumböck

To unsubscribe, e-mail:   <>
For additional commands, e-mail: <>

View raw message