tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Christopher Watson" <c.wat...@zen.co.uk>
Subject Can anyone help with an SSL problem?
Date Fri, 20 Sep 2002 09:03:27 GMT
Dear All,

Can anyone offer some advice - sorry to keep asking, but so far I've had no
reply :-(

I am using ISAPI redirector to serve JSP/servlet resources through IIS

I would like some contexts to _require_ SSL (https) to be used, and leave
others free to use http.

I am able require _all_ contexts to use SSL by setting 'require secure
channel'
for the jakarta virtual directory under IIS.

BUT

What I want to do is require SSL at a _context_ level

Can someone show me how to do this,
perhaps using workers.properties or uriworkermap.properties or the like?

I did think of setting secure="true" on the ajp13 connnector,
but that just tells effectively tells me that that connector has been used,
not whether the original request used SSL - in other words I ALWAYS get
isSecure()  = whatever was set for the connector in server.xml

An idea I had was to have more than one 'jakarta' virtual directory, one
requiring SSL, the other not,
but then I'm guessing the ISAPI filter uses the same Registry entry,
so I couldn't specify a different extension_uri to get to it ??
Is this the right thinking?? Is there a way round this?

Any other general advice - except "don't use IIS" (I have no choice for this
project!) - would be welcome.

Christopher


--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message