tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vincent.Gabor...@answare.fr
Subject RE: Apache 1.3.26 to Tomcat 4.0.4 PROBLEM with mod-Jk on solaris
Date Thu, 12 Sep 2002 15:18:57 GMT
First
	<Engine name="Standalone" defaultHost="localhost" debug="0">

must be :

	<Engine name="Standalone" defaultHost="ebusiness.corp.teradyne.com"
debug="0">

In your workers.properties, you have:
	 worker.ajp13.host=ebusiness.corp.teradyne.com

Is "ebusiness.corp.teradyne.com" knowned? "ebusiness.corp.teradyne.com" must
be a machine name.

You must specify the host in the workers.properties when Tomcat is installed
in a different machine than Apache. If it's not the case you can let that as
localhost.

-----Message d'origine-----
De : Habibak haAlbek [mailto:habibak73@yahoo.com]
Envoye : jeudi 12 septembre 2002 16:57
A : tomcat-user@jakarta.apache.org
Objet : Apache 1.3.26 to Tomcat 4.0.4 PROBLEM with mod-Jk on solaris



Still hangs. Apache alone works fine. TomCat alone works fine. something is
wrong with the connector configuration. here's what I have:

1- Server.xml :



- <Server port="8005" shutdown="SHUTDOWN" debug="0">

  <Listener className="org.apache.ajp.tomcat4.config.ApacheConfig" />



- <Service name="Tomcat-Standalone">





  <Connector className="org.apache.catalina.connector.http.HttpConnector"
port="8080" minProcessors="5" maxProcessors="75" enableLookups="true"
redirectPort="8443" acceptCount="10" debug="0" connectionTimeout="60000" />







  <Connector className="org.apache.ajp.tomcat4.Ajp13Connector" port="8009"
minProcessors="5" maxProcessors="75" acceptCount="10" debug="10" />







- <Engine name="Standalone" defaultHost="localhost" debug="0">



  <Logger className="org.apache.catalina.logger.FileLogger"
prefix="catalina_log." suffix=".txt" timestamp="true" />

  <Realm className="org.apache.catalina.realm.MemoryRealm" />





- <Host name="ebusiness.corp.teradyne.com" debug="0" appBase="webapps"
unpackWARs="true">

  <Listener className="org.apache.ajp.tomcat4.config.ApacheConfig"
append="true" forwardAll="false" />

  <Valve className="org.apache.catalina.valves.AccessLogValve"
directory="logs" prefix="localhost_access_log." suffix=".txt"
pattern="common" />



  <Logger className="org.apache.catalina.logger.FileLogger" directory="logs"
prefix="localhost_log." suffix=".txt" timestamp="true" />





  <Context path="/manager" docBase="manager" debug="0" privileged="true" />



+ <Context path="/examples" docBase="examples" debug="0" reloadable="true"
crossContext="true">

  <Logger className="org.apache.catalina.logger.FileLogger"
prefix="localhost_examples_log." suffix=".txt" timestamp="true" />

  <Ejb name="ejb/EmplRecord" type="Entity"
home="com.wombat.empl.EmployeeRecordHome"
remote="com.wombat.empl.EmployeeRecord" />









  -->f(clean);

  <Environment name="maxExemptions" type="java.lang.Integer" value="15" />

  <Parameter name="context.param.name" value="context.param.value"
override="false" />

  <Resource name="jdbc/EmployeeAppDb" auth="SERVLET"
type="javax.sql.DataSource" />

- <ResourceParams name="jdbc/EmployeeAppDb">

- <parameter>

  <name>user</name>

  <value>sa</value>

  </parameter>

- <parameter>

  <name>password</name>

  <value />

  </parameter>

- <parameter>

  <name>driverClassName</name>

  <value>org.hsql.jdbcDriver</value>

  </parameter>

- <parameter>

  <name>driverName</name>

  <value>jdbc:HypersonicSQL:database</value>

  </parameter>

  </ResourceParams>

  <Resource name="mail/Session" auth="Container" type="javax.mail.Session"
/>

- <ResourceParams name="mail/Session">

- <parameter>

  <name>mail.smtp.host</name>

  <value>localhost</value>

  </parameter>

  </ResourceParams>

  </Context>

  </Host>

  </Engine>

  </Service>



- <Service name="Tomcat-Apache">



- <Engine className="org.apache.catalina.connector.warp.WarpEngine"
name="Apache" debug="0">



  <Logger className="org.apache.catalina.logger.FileLogger"
prefix="apache_log." suffix=".txt" timestamp="true" />



  <Realm className="org.apache.catalina.realm.MemoryRealm" />

  </Engine>

  </Service>

  </Server>



2. workers.properties looks like this:
#
# workers.properties
#
worker.list=ajp12, ajp13
workers.tomcat_home=/export/home/eapps/apacheTomCat/jakarta-tomcat-4.0.4
workers.java_home=/usr/java1.2
ps=/
worker.ajp13.port=8009
worker.ajp13.host=ebusiness.corp.teradyne.com
worker.ajp13.type=ajp13
#
# END workers.properties
#

3. JDK version is 1.2.2_05a

4. httpd.conf contains the following lines
LoadModule jk_module libexec/mod_jk.so (I even downloaded another so than
then the one I have compiled)
AddModule mod_jk.c
JkWorkersFile /apache-dir/conf/workers.properties
JkLogFile /apache-dir/logs/mod_jk.log
JkLogLevel debug
JkMount /*.jsp ajp13
JkMount /servlet/* ajp13

it can not be simpler than that configuration wise, at this point It is
becoming frustrating not having a clue what's going on! Thanks for your
help!



---------------------------------
Do you Yahoo!?
Yahoo! News - Today's headlines


--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message