tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Adam Greene" <agre...@romulin.com>
Subject Discovered Problem with " Broken Class Loader in 4.1.12"
Date Thu, 26 Sep 2002 14:02:58 GMT
Never Mind.  I simply removed the / from in front of com/creditunion and it
found it.  I'm not sure which way is the correct way, but none-the-less, it
works now.

-----Original Message-----
From: Adam Greene [mailto:agreene@romulin.com]
Sent: Thursday, September 26, 2002 11:00 AM
To: Tomcat Users List
Subject: Broken Class Loader in 4.1.12


Here is the configuration:

Under C:\Tomcat4.1.12\common\classes is a central code set for several
different websites.  In the subdirectory /com/creditunion is a file called
"Torque.properties"
Under C:\Tomcat4.1.12\common\lib is the torque.jar file
Under
C:\Tomcat4.1.12\creditunions\creditunionX\WEB-INF\classes\com\creditunion\Cr
editUnionServlet.class
In CreditUnionServlet in the init() is the following line:

InputStream input =
getClass().getClassLoader().getResourceAsStream("/com/creditunion/Torque.pro
perties");

This worked fine under Tomcat 4.1.10, but is now broken under Tomcat 4.1.12.



--
To unsubscribe, e-mail:
<mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail:
<mailto:tomcat-user-help@jakarta.apache.org>



--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message