tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Miguel Angel Mulero Martinez <miguel-angel.mul...@mad.tecsidel.es>
Subject RE: Bug in 4.1.10?
Date Thu, 12 Sep 2002 09:38:56 GMT
The user is LocalSystem (the same that other services and the same I used in
the old version of Tomcat), and the problem isn't in the compilation of a
JSP, the problem is in the compilation of the JSP when it uses (import)
classes under WEB-INF/classes or WEB-INF/lib. I tried the tomcat examples
and, for example, the date example don't work.

Can you try this example?

Thanks!
-----Mensaje original-----
De: Ben Walding [mailto:ben@walding.com]
Enviado el: jueves, 12 de septiembre de 2002 10:54
Para: Tomcat Users List
Asunto: Re: Bug in 4.1.10?

You haven't done something odd with file permissions / quotas have you?

I can't recall offhand what user the service runs as, but you could try
setting it to run as the same user as you are logged in as.

We are using TomCat 4.1.10 on Win2K SP3 with JDK 1.4.0_01, and JSPs do
compile (well the /index.jsp  which is the only one we use).

Miguel Angel Mulero Martinez wrote:

>I just have joining to he list, and I have searched in the old messages but
>I haven't found this:
>
>I have installed the new Tomcat 4.1.10, under Win2000. My problem is that
if
>I execute it like a windows service, Tomcat give me errors compiling any
JSP
>because it don't find the classes under WEB-INF/classes or WEB-INF/lib. If
I
>execute tomcat in the command line (catalina start), all works perfectly.
If
>after execute from the command line, I stopped it and start Tomcat like a
>service, now it works but only the pages visited when I started it from the
>command line (pages already compiled).
>
>A friend of mine has the same problem.
>
>Someone with win2000, JDK 1.4.0_01 has tried tomcat like a service?
>
>Thanks!!
>
>
>--
>To unsubscribe, e-mail:
<mailto:tomcat-user-unsubscribe@jakarta.apache.org>
>For additional commands, e-mail:
<mailto:tomcat-user-help@jakarta.apache.org>
>
>
>
>




--
To unsubscribe, e-mail:
<mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail:
<mailto:tomcat-user-help@jakarta.apache.org>


--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message