tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Richard Chamberlain <rich...@sunsetandlabrea.com>
Subject Re: virtualhost - tomcat4.1.9
Date Wed, 04 Sep 2002 19:21:13 GMT
Hello again,

I'll answer my own question just in case someone else comes unstuck with 
the same problem.

It appears if you create a context using the admin tool and leave the 
path empty when it creates the path it adds a path='/' which is not 
correct. Deleting the / manually solves it.

Cheers,

Richard

On Wednesday, September 4, 2002, at 02:30 PM, Richard Chamberlain wrote:

> Hello,
>
> I posted this earlier problem earlier in my migration post but I've got
> some more details so I thought I'd post them.
>
> To recap I'm trying to get a webapp (well a simple set of jsp pages)
> running in Tomcat in a virtualhost. The same set of files were all ok
> in resin.
>
> I'm using the admin tool to set up a host (www.sunsetandlabrea.com)
> with an application base of /home/richardc/
>
> I then create a context with a document base of
> /home/richardc/public_html/ and leave everything else as default.
>
> I commit changes and then I get a 404 error at
> http://www.sunsetandlabrea.com:8080/index.jsp
>
> I stop and restart tomcat and then I get a No Context configured to
> process this request message and in admin it's created two new contexts
> (/public_html and /secure_html).
>
> Any suggestions of how I can get this to work would be greatly
> appreciated.
>
> I've stuck the log at the bottom of this message.
>
> Thanks again,
>
> Richard


--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message