tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From William Wragg <will...@datapro.co.uk>
Subject No Context configured to process this request
Date Fri, 13 Sep 2002 13:35:42 GMT
Hi,

I am using tomcat 4.0.4 on sco openserver 5.0.5a with JDK1.3_02. I have 
installed the exact same setup and webapps on many machines (linux and 
windows as well as sco), and they have all worked fine. I have just 
installed on another machine and the client gets the following error 
message when they try to go to a page:

Apache Tomcat/4.0.4 - HTTP Status 500 - No Context configured to process 
this request

type Status report
message No Context configured to process this request
description The server encountered an internal error (No Context configured 
to process this request) that prevented it from fulfilling this request.

The error message also appears when they try to use the manager webapp. 
Looking at the localhost_log the contexts seem to have been created, or at 
least the log looks just the same as the log entries from a working site:

2002-09-13 13:16:19 WebappLoader[/manager]: Deploying class repositories to 
work
  directory /u1/pharaoh/jakarta-tomcat-4.0.4/work/Standalone/localhost/manager
2002-09-13 13:16:19 StandardManager[/manager]: Seeding random number 
generator c
lass java.security.SecureRandom
2002-09-13 13:16:19 StandardManager[/manager]: Seeding of random number 
generato
r has been completed
2002-09-13 13:16:20 ContextConfig[/manager]: Configured an authenticator 
for met
hod BASIC
2002-09-13 13:16:20 StandardWrapper[/manager:default]: Loading container 
servlet
  default
2002-09-13 13:16:20 default: init
2002-09-13 13:16:20 StandardWrapper[/manager:invoker]: Loading container 
servlet
  invoker
2002-09-13 13:16:20 invoker: init
2002-09-13 13:16:20 jsp: init
2002-09-13 13:16:21 WebappLoader[/jobreq]: Deploying class repositories to work
directory /u1/pharaoh/jakarta-tomcat-4.0.4/work/Standalone/localhost/jobreq
2002-09-13 13:16:21 WebappLoader[/jobreq]: Deploy JAR 
/WEB-INF/lib/application.j
ar to 
/u1/pharaoh/jakarta-tomcat-4.0.4/webapps/jobreq/WEB-INF/lib/application.ja
r
2002-09-13 13:16:21 WebappLoader[/jobreq]: Deploy JAR /WEB-INF/lib/datetime.jar
to /u1/pharaoh/jakarta-tomcat-4.0.4/webapps/jobreq/WEB-INF/lib/datetime.jar
2002-09-13 13:16:21 WebappLoader[/jobreq]: Deploy JAR 
/WEB-INF/lib/dbtags.jar to
  /u1/pharaoh/jakarta-tomcat-4.0.4/webapps/jobreq/WEB-INF/lib/dbtags.jar
2002-09-13 13:16:21 WebappLoader[/jobreq]: Deploy JAR 
/WEB-INF/lib/mailer.jar to
  /u1/pharaoh/jakarta-tomcat-4.0.4/webapps/jobreq/WEB-INF/lib/mailer.jar
2002-09-13 13:16:21 WebappLoader[/jobreq]: Deploy JAR 
/WEB-INF/lib/request.jar t
o /u1/pharaoh/jakarta-tomcat-4.0.4/webapps/jobreq/WEB-INF/lib/request.jar
2002-09-13 13:16:21 WebappLoader[/jobreq]: Deploy JAR 
/WEB-INF/lib/session.jar t
o /u1/pharaoh/jakarta-tomcat-4.0.4/webapps/jobreq/WEB-INF/lib/session.jar
2002-09-13 13:16:21 WebappLoader[/jobreq]: Reloading checks are enabled for 
this
  Context
2002-09-13 13:16:21 StandardManager[/jobreq]: Seeding random number 
generator cl
ass java.security.SecureRandom
2002-09-13 13:16:21 StandardManager[/jobreq]: Seeding of random number 
generator
  has been completed
2002-09-13 13:16:23 StandardWrapper[/jobreq:default]: Loading container servlet
default
2002-09-13 13:16:23 default: init
2002-09-13 13:16:23 StandardWrapper[/jobreq:invoker]: Loading container servlet
invoker
2002-09-13 13:16:23 invoker: init
2002-09-13 13:16:23 jsp: init
2002-09-13 13:16:32 jsp: init
2002-09-13 13:16:33 jsp: init
2002-09-13 13:16:35 jsp: init
2002-09-13 13:16:42 StandardHost[localhost]: MAPPING configuration error 
for req
uest URI

The MAPPING error is me trying to connect to http://<SERVER>:8080/jobreq

Does anyone know what is happening it's driving me nuts.

Regards,

Wm.


Mime
View raw message